# CVE-2025-22130: Soft Serve allows path traversal attacks

> Attackers can exploit path traversal to access and modify other users' repositories, effectively gaining admin privileges without authorization.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jan 2025
- **Updated:** 8 Jan 2025
- **Also known as:** GHSA-j4jw-m6xr-fv6c, GO-2025-3374

## What is CVE-2025-22130?

CVE-2025-22130 is a medium-severity path traversal vulnerability in charmbracelet soft-serve, published on 8 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Soft Serve is a self-hostable Git server for the command line. Prior to 0.8.2 , a path traversal attack allows existing non-admin users to access and take over other user's repositories. A malicious user then can modify, delete, and arbitrarily repositories as if they were an admin user without explicitly giving them permissions. This is patched in v0.8.2.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-22130?

3 open source packages ship an affected version, including github.com/charmbracelet/soft-serve. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/charmbracelet/soft-serve` | Go | All versions | 0.8.2 |
| `github.com/charmbracelet/soft-serve` | Go | All versions | 0.8.2 |
| `github.com/charmbracelet/soft-serve` | Go | All versions | 0.8.2 |

Products: Charm Soft Serve.

## How do I fix CVE-2025-22130?

Upgrade github.com/charmbracelet/soft-serve to 0.8.2 or later.

## Is CVE-2025-22130 being exploited?

There is no known exploitation of CVE-2025-22130 in the wild and no public exploit code.

## Other vulnerabilities in charmbracelet soft-serve

- [CVE-2026-30832](https://insights.sbomify.com/CVE-2026-30832/): Soft Serve: SSRF via unvalidated LFS endpoint in repo import (critical 9.1)
- [CVE-2025-64522](https://insights.sbomify.com/CVE-2025-64522/): Soft Serve is vulnerable to SSRF through its Webhooks (critical 9.1)
- [CVE-2026-24058](https://insights.sbomify.com/CVE-2026-24058/): Soft Serve has Critical Authentication Bypass (high 8.1)
- [CVE-2023-43809](https://insights.sbomify.com/CVE-2023-43809/): Soft Serve Public Key Authentication Bypass Vulnerability when Keyboard-Interactive SSH Authentication is Enabled (high 7.5)
- [CVE-2026-33353](https://insights.sbomify.com/CVE-2026-33353/): Soft Serve: Authenticated repo import can clone server-local private repositories (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-22130 and fix it if it is affected.

What it is: CVE-2025-22130 is a medium-severity path traversal vulnerability in charmbracelet soft-serve, published on 8 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-22130 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/charmbracelet/soft-serve (Go): affected all versions; fixed in 0.8.2
- github.com/charmbracelet/soft-serve (Go): affected all versions; fixed in 0.8.2
- github.com/charmbracelet/soft-serve (Go): affected all versions; fixed in 0.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-22130/ (Markdown: https://insights.sbomify.com/CVE-2025-22130/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-22130
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-22130
- OSV: https://osv.dev/vulnerability/CVE-2025-22130

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-22130/
Summaries are generated and may contain mistakes; the official description above is the record.
