{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-22136 exists.","fix":"No fix has been published for CVE-2025-22136 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-22136 is a high-severity code injection vulnerability in Eugeny tabby, published on 8 Jan 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-22136 and fix it if it is affected.\n\nWhat it is: CVE-2025-22136 is a high-severity code injection vulnerability in Eugeny tabby, published on 8 Jan 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-22136 exists.\n\nAffected product: Eugeny tabby. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-22136/ (Markdown: https://insights.sbomify.com/CVE-2025-22136/index.md)","id":"CVE-2025-22136","markdown":"https://insights.sbomify.com/CVE-2025-22136/index.md","name":"CVE-2025-22136","record":{"aliases":["GHSA-prcj-7rvc-26h4"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Terminal emulator","requires_auth":"none","summary":"Attackers can execute arbitrary code in Tabby terminal emulator by exploiting misconfigured Electron fuses that allow Node.js injection.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Tabby (formerly Terminus) is a highly configurable terminal emulator. Prior to 1.0.217 , Tabby enables several high-risk Electron Fuses, including RunAsNode, EnableNodeCliInspectArguments, and EnableNodeOptionsEnvironmentVariable. These fuses create potential code injection vectors even though the application is signed with hardened runtime and lacks dangerous entitlements such as com.apple.security.cs.disable-library-validation and com.apple.security.cs.allow-dyld-environment-variables. This vulnerability is fixed in 1.0.217.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Tabby has a TCC Bypass via Misconfigured Node Fuses","id":"CVE-2025-22136","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"code_injection","year":"2025"},"n_packages":0,"n_references":2,"next":{"headline":"Arbitrary File Overwrite via HTTP POST in Pingvin Share","id":"CVE-2025-22137"},"packages":[],"prev":{"headline":"heap-buffer-overflow with visual mode in Vim \u003c 9.1.1003","id":"CVE-2025-22134"},"products":["tabby"],"published":"2025-01-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-01-08","vendors":["Eugeny"]},"summary":"Attackers can execute arbitrary code in Tabby terminal emulator by exploiting misconfigured Electron fuses that allow Node.js injection.","url":"https://insights.sbomify.com/CVE-2025-22136/"}