{"answers":{"affected":"3 open source packages ship an affected version, including sentry.","exploited":"There is no known exploitation of CVE-2025-22146 in the wild and no public exploit code.","fix":"Upgrade sentry to 25.1.0 or later.","what":"CVE-2025-22146 is a critical authentication bypass vulnerability in getsentry sentry, published on 15 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-22146 and fix it if it is affected.\n\nWhat it is: CVE-2025-22146 is a critical authentication bypass vulnerability in getsentry sentry, published on 15 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-22146 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sentry (PyPI): affected from 21.12.0; fixed in 25.1.0\n- sentry (PyPI): affected from 21.12.0; fixed in 25.1.0\n- sentry (PyPI): affected from 21.12.0; fixed in 25.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-22146/ (Markdown: https://insights.sbomify.com/CVE-2025-22146/index.md)","id":"CVE-2025-22146","markdown":"https://insights.sbomify.com/CVE-2025-22146/index.md","name":"CVE-2025-22146","record":{"aliases":["GHSA-7pq6-v88g-wf3w","PYSEC-2026-532"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Sentry error tracking","requires_auth":"none","summary":"Attackers can impersonate users via malicious SAML SSO if multiple organizations are enabled, requiring an upgrade to fix.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"Sentry is a developer-first error tracking and performance monitoring tool. A critical vulnerability was discovered in the SAML SSO implementation of Sentry. It was reported to us via our private bug bounty program. The vulnerability allows an attacker to take over any user account by using a malicious SAML Identity Provider and another organization on the same Sentry instance. The victim email address must be known in order to exploit this vulnerability. The Sentry SaaS fix was deployed on Jan 14, 2025. For self hosted users; if only a single organization is allowed `(SENTRY_SINGLE_ORGANIZATION = True)`, then no action is needed. Otherwise, users should upgrade to version 25.1.0 or higher. There are no known workarounds for this vulnerability.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper authentication on SAML SSO process allows user impersonation in sentry","id":"CVE-2025-22146","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"JWK Set's HTTP client only overwrites and appends JWK to local cache during refresh","id":"CVE-2025-22149"},"packages":[{"ecosystem":"PyPI","fixed":["25.1.0"],"introduced":["21.12.0"],"last_affected":[],"package":"sentry","purl":null,"source":"GHSA-7pq6-v88g-wf3w"},{"ecosystem":"PyPI","fixed":["25.1.0"],"introduced":["21.12.0"],"last_affected":[],"package":"sentry","purl":"pkg:pypi/sentry","source":"GHSA-7pq6-v88g-wf3w"},{"ecosystem":"PyPI","fixed":["25.1.0"],"introduced":["21.12.0"],"last_affected":[],"package":"sentry","purl":"pkg:pypi/sentry","source":"PYSEC-2026-532"}],"prev":{"headline":"Carbon has an arbitrary file include via unvalidated input passed to Carbon::setLocale","id":"CVE-2025-22145"},"products":["sentry"],"published":"2025-01-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-01-15","vendors":["getsentry"]},"summary":"Attackers can impersonate users via malicious SAML SSO if multiple organizations are enabled, requiring an upgrade to fix.","url":"https://insights.sbomify.com/CVE-2025-22146/"}