{"answers":{"affected":"6 open source packages ship an affected version, including undici.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-22150 exists.","fix":"Upgrade undici to a fixed version for your release line: 5.28.5, 6.21.1 or 7.2.3.","what":"CVE-2025-22150 is a medium-severity vulnerability in nodejs undici, published on 21 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-22150 and fix it if it is affected.\n\nWhat it is: CVE-2025-22150 is a medium-severity vulnerability in nodejs undici, published on 21 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-22150 exists.\n\nAffected packages and fixed versions:\n- undici (npm): affected from 4.5.0; fixed in 5.28.5\n- undici (npm): affected from 4.5.0; fixed in 5.28.5\n- undici (npm): affected from 6.0.0; fixed in 6.21.1\n- undici (npm): affected from 6.0.0; fixed in 6.21.1\n- undici (npm): affected from 7.0.0; fixed in 7.2.3\n- undici (npm): affected from 7.0.0; fixed in 7.2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-22150/ (Markdown: https://insights.sbomify.com/CVE-2025-22150/index.md)","id":"CVE-2025-22150","markdown":"https://insights.sbomify.com/CVE-2025-22150/index.md","name":"CVE-2025-22150","record":{"aliases":["ALPINE-CVE-2025-22150","AZL-55931","AZL-55950","BELL-CVE-2025-22150","CLSA-2025-1758102713","DEBIAN-CVE-2025-22150","ECHO-e503-e375-1d79","GHSA-c76h-2ccp-4975","MINI-hwvv-359q-8cr5","MINI-j3mr-4f8v-7r4c","MINI-qj3h-grvq-3wrr","ROOT-APP-NPM-CVE-2025-22150","ROOT-OS-DEBIAN-12-CVE-2025-22150","UBUNTU-CVE-2025-22150"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js HTTP client","requires_auth":"none","summary":"Attackers can predict multipart boundaries in Undici HTTP client requests, allowing them to tamper with data sent to backend APIs.","user_interaction":"required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-330","name":"Use of Insufficiently Random Values"}],"description":"Undici is an HTTP/1.1 client. Starting in version 4.5.0 and prior to versions 5.28.5, 6.21.1, and 7.2.3, undici uses `Math.random()` to choose the boundary for a multipart/form-data request. It is known that the output of `Math.random()` can be predicted if several of its generated values are known. If there is a mechanism in an app that sends multipart requests to an attacker-controlled website, they can use this to leak the necessary values. Therefore, an attacker can tamper with the requests going to the backend APIs if certain conditions are met. This is fixed in versions 5.28.5, 6.21.1, and 7.2.3. As a workaround, do not issue multipart requests to attacker controlled servers.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Undici Uses Insufficiently Random Values","id":"CVE-2025-22150","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"weak_cryptography","year":"2025"},"n_packages":6,"n_references":7,"next":{"headline":"Strawberry GraphQL has a type resolution vulnerability","id":"CVE-2025-22151"},"packages":[{"ecosystem":"npm","fixed":["5.28.5"],"introduced":["4.5.0"],"last_affected":[],"package":"undici","purl":null,"source":"GHSA-c76h-2ccp-4975"},{"ecosystem":"npm","fixed":["5.28.5"],"introduced":["4.5.0"],"last_affected":[],"package":"undici","purl":"pkg:npm/undici","source":"GHSA-c76h-2ccp-4975"},{"ecosystem":"npm","fixed":["6.21.1"],"introduced":["6.0.0"],"last_affected":[],"package":"undici","purl":null,"source":"GHSA-c76h-2ccp-4975"},{"ecosystem":"npm","fixed":["6.21.1"],"introduced":["6.0.0"],"last_affected":[],"package":"undici","purl":"pkg:npm/undici","source":"GHSA-c76h-2ccp-4975"},{"ecosystem":"npm","fixed":["7.2.3"],"introduced":["7.0.0"],"last_affected":[],"package":"undici","purl":null,"source":"GHSA-c76h-2ccp-4975"},{"ecosystem":"npm","fixed":["7.2.3"],"introduced":["7.0.0"],"last_affected":[],"package":"undici","purl":"pkg:npm/undici","source":"GHSA-c76h-2ccp-4975"}],"prev":{"headline":"JWK Set's HTTP client only overwrites and appends JWK to local cache during refresh","id":"CVE-2025-22149"},"products":["undici"],"published":"2025-01-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-12","vendors":["nodejs"]},"summary":"Attackers can predict multipart boundaries in Undici HTTP client requests, allowing them to tamper with data sent to backend APIs.","url":"https://insights.sbomify.com/CVE-2025-22150/"}