# CVE-2025-22153: try/except* clauses could allow bypass RestrictedPython via type confusion bug in the CPython interpreter

> A type confusion bug in CPython allows attackers to bypass RestrictedPython sandbox restrictions, potentially executing unauthorized code.

- **Severity:** High 7.9 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jan 2025
- **Updated:** 12 Feb 2025
- **Also known as:** DEBIAN-CVE-2025-22153, GHSA-gmj9-h825-chq2, PYSEC-2026-1874, UBUNTU-CVE-2025-22153

## What is CVE-2025-22153?

CVE-2025-22153 is a high-severity vulnerability in zopefoundation RestrictedPython, published on 23 Jan 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

RestrictedPython is a tool that helps to define a subset of the Python language which allows to provide a program input into a trusted environment. Via a type confusion bug in versions of the CPython interpreter starting in 3.11 and prior to 3.13.2 when using `try/except*`, RestrictedPython starting in version 6.0 and prior to version 8.0 could be bypassed. The issue is patched in version 8.0 of RestrictedPython by removing support for `try/except*` clauses. No known workarounds are available.

Weakness: CWE-843 (Access of Resource Using Incompatible Type)

## Which versions are affected by CVE-2025-22153?

3 open source packages ship an affected version, including restrictedpython and RestrictedPython.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `restrictedpython` | PyPI | From 6.0 | 8.0 |
| `restrictedpython` | PyPI | From 6.0 | 8.0 |
| `RestrictedPython` | PyPI | From 6.0 | 8.0 |

## How do I fix CVE-2025-22153?

Upgrade restrictedpython to 8.0 or later.

## Is CVE-2025-22153 being exploited?

There is no known exploitation of CVE-2025-22153 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-22153 and fix it if it is affected.

What it is: CVE-2025-22153 is a high-severity vulnerability in zopefoundation RestrictedPython, published on 23 Jan 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-22153 in the wild and no public exploit code.

Affected packages and fixed versions:
- restrictedpython (PyPI): affected from 6.0; fixed in 8.0
- restrictedpython (PyPI): affected from 6.0; fixed in 8.0
- RestrictedPython (PyPI): affected from 6.0; fixed in 8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-22153/ (Markdown: https://insights.sbomify.com/CVE-2025-22153/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-22153
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-22153
- OSV: https://osv.dev/vulnerability/CVE-2025-22153

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-22153/
Summaries are generated and may contain mistakes; the official description above is the record.
