# CVE-2025-22223: Spring Security Vulnerable to Authorization Bypass via Security Annotations

> Attackers can bypass method security checks on parameterized types in Spring Security, potentially accessing protected functionality without authorization.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Mar 2025
- **Updated:** 24 Mar 2025
- **Also known as:** CLEANSTART-2026-MT60008, GHSA-hh3m-g4qj-4835, MINI-4hv9-68x6-2x4g, MINI-vfrm-qwf2-gq3m

## What is CVE-2025-22223?

CVE-2025-22223 is a medium-severity missing authorization vulnerability in Spring Security, published on 24 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Spring Security 6.4.0 - 6.4.3 may not correctly locate method security annotations on parameterized types or methods. This may cause an authorization bypass. 

You are not affected if you are not using @EnableMethodSecurity, or
you do not have method security annotations on parameterized types or methods, or all method security annotations are attached to target methods

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2025-22223?

2 open source packages ship an affected version, including org.springframework.security:spring-security-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.security:spring-security-core` | Maven | From 6.4.0 | 6.4.4 |
| `org.springframework.security:spring-security-core` | Maven | From 6.4.0 | 6.4.4 |

## How do I fix CVE-2025-22223?

Upgrade org.springframework.security:spring-security-core to 6.4.4 or later.

## Is CVE-2025-22223 being exploited?

There is no known exploitation of CVE-2025-22223 in the wild and no public exploit code.

Public exploit code:

- cve-2025-22223 漏洞复现 (github_poc): https://github.com/1ucky7/cve-2025-22223-demo-1.0.0

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-22223 and fix it if it is affected.

What it is: CVE-2025-22223 is a medium-severity missing authorization vulnerability in Spring Security, published on 24 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-22223 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.security:spring-security-core (Maven): affected from 6.4.0; fixed in 6.4.4
- org.springframework.security:spring-security-core (Maven): affected from 6.4.0; fixed in 6.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-22223/ (Markdown: https://insights.sbomify.com/CVE-2025-22223/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-22223
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-22223
- OSV: https://osv.dev/vulnerability/CVE-2025-22223

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-22223/
Summaries are generated and may contain mistakes; the official description above is the record.
