# CVE-2025-22233: Spring Framework DataBinder Case Sensitive Match Exception

> Attackers can bypass disallowedFields checks in Spring Framework DataBinder to modify protected object properties, requiring an upgrade to fixed versions.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 May 2025
- **Updated:** 17 May 2025
- **Also known as:** CLEANSTART-2026-NT49717, CLEANSTART-2026-UT02343, CLSA-2025-1752537764, CLSA-2026-1793094381, DEBIAN-CVE-2025-22233, ECHO-e634-10ea-902d, GHSA-4wp7-92pw-q264, MINI-5h6j-w98g-3rh7, MINI-7p54-m624-p84p, MINI-chq2-w4p8-rx98, MINI-f6rr-x3mx-62mq, MINI-g5g4-348f-crfp, MINI-vqpx-6h2j-fv4r, MINI-wpvr-ww72-g43x, UBUNTU-CVE-2025-22233

## What is CVE-2025-22233?

CVE-2025-22233 is a low-severity missing authorization vulnerability in Spring Framework, published on 16 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

CVE-2024-38820 ensured Locale-independent, lowercase conversion for both the configured disallowedFields patterns and for request parameter names. However, there are still cases where it is possible to bypass the disallowedFields checks.

Affected Spring Products and Versions

Spring Framework:
  *  6.2.0 - 6.2.6

  *  6.1.0 - 6.1.19

  *  6.0.0 - 6.0.27

  *  5.3.0 - 5.3.42
  *  Older, unsupported versions are also affected

Mitigation

Users of affected versions should upgrade to the corresponding fixed version.

Affected version(s)Fix Version Availability 6.2.x
 6.2.7
OSS6.1.x
 6.1.20
OSS6.0.x
 6.0.28
 Commercial https://enterprise.spring.io/ 5.3.x
 5.3.43
 Commercial https://enterprise.spring.io/ 
No further mitigation steps are necessary.

Generally, we recommend using a dedicated model object with properties only for data binding, or using constructor binding since constructor arguments explicitly declare what to bind together with turning off setter binding through the declarativeBinding flag. See the Model Design section in the reference documentation.

For setting binding, prefer the use of allowedFields (an explicit list) over disallowedFields.

Credit

This issue was responsibly reported by the TERASOLUNA Framework Development Team from NTT DATA Group Corporation.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-22233?

8 open source packages ship an affected version, including org.springframework:spring-context.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework:spring-context` | Maven | All versions to 5.3.39 | None |
| `org.springframework:spring-context` | Maven | All versions to 5.3.39 | None |
| `org.springframework:spring-context` | Maven | From 6.0.0 to 6.0.23 | None |
| `org.springframework:spring-context` | Maven | From 6.0.0 to 6.0.23 | None |
| `org.springframework:spring-context` | Maven | From 6.1.0 | 6.1.20 |
| `org.springframework:spring-context` | Maven | From 6.1.0 | 6.1.20 |
| `org.springframework:spring-context` | Maven | From 6.2.0 | 6.2.7 |
| `org.springframework:spring-context` | Maven | From 6.2.0 | 6.2.7 |

## How do I fix CVE-2025-22233?

Upgrade org.springframework:spring-context to a fixed version for your release line: 6.1.20 or 6.2.7.

## Is CVE-2025-22233 being exploited?

There is no known exploitation of CVE-2025-22233 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-22233 and fix it if it is affected.

What it is: CVE-2025-22233 is a low-severity missing authorization vulnerability in Spring Framework, published on 16 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-22233 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework:spring-context (Maven): affected all versions up to 5.3.39; no fix listed
- org.springframework:spring-context (Maven): affected all versions up to 5.3.39; no fix listed
- org.springframework:spring-context (Maven): affected from 6.0.0 up to 6.0.23; no fix listed
- org.springframework:spring-context (Maven): affected from 6.0.0 up to 6.0.23; no fix listed
- org.springframework:spring-context (Maven): affected from 6.1.0; fixed in 6.1.20
- org.springframework:spring-context (Maven): affected from 6.1.0; fixed in 6.1.20
- org.springframework:spring-context (Maven): affected from 6.2.0; fixed in 6.2.7
- org.springframework:spring-context (Maven): affected from 6.2.0; fixed in 6.2.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-22233/ (Markdown: https://insights.sbomify.com/CVE-2025-22233/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-22233
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-22233
- OSV: https://osv.dev/vulnerability/CVE-2025-22233

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-22233/
Summaries are generated and may contain mistakes; the official description above is the record.
