# CVE-2025-22236: CVE-2025-22236 salt advisory

> An attacker with a minion key can bypass authorization to execute jobs on other minions, leading to potential code execution and privilege escalation.

- **Severity:** High 8.1 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jun 2025
- **Updated:** 13 Jun 2025
- **Also known as:** GHSA-jh7c-xh74-h76f, PYSEC-2026-1899, UBUNTU-CVE-2025-22236

## What is CVE-2025-22236?

CVE-2025-22236 is a high-severity authentication bypass vulnerability in VMware SALT, published on 13 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Minion event bus authorization bypass. An attacker with access to a minion key can craft a message which may be able to execute a job on other minions (>= 3007.0).

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2025-22236?

5 open source packages ship an affected version, including salt.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `salt` | PyPI | From 3006.0 | 3006.12, 3007.4 |
| `salt` | PyPI | From 3006.0 | 3006.12 |
| `salt` | PyPI | From 3006.0 | 3006.12 |
| `salt` | PyPI | From 3007.0 | 3007.4 |
| `salt` | PyPI | From 3007.0 | 3007.4 |

## How do I fix CVE-2025-22236?

Upgrade salt to a fixed version for your release line: 3006.12 or 3007.4.

## Is CVE-2025-22236 being exploited?

There is no known exploitation of CVE-2025-22236 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-22236 and fix it if it is affected.

What it is: CVE-2025-22236 is a high-severity authentication bypass vulnerability in VMware SALT, published on 13 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-22236 in the wild and no public exploit code.

Affected packages and fixed versions:
- salt (PyPI): affected from 3006.0; fixed in 3006.12, 3007.4
- salt (PyPI): affected from 3006.0; fixed in 3006.12
- salt (PyPI): affected from 3006.0; fixed in 3006.12
- salt (PyPI): affected from 3007.0; fixed in 3007.4
- salt (PyPI): affected from 3007.0; fixed in 3007.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-22236/ (Markdown: https://insights.sbomify.com/CVE-2025-22236/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-22236
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-22236
- OSV: https://osv.dev/vulnerability/CVE-2025-22236

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-22236/
Summaries are generated and may contain mistakes; the official description above is the record.
