# CVE-2025-22374: SSRF in CyberAudit-Web videx-legacy-ssl

> An SSRF vulnerability in CyberAudit-Web allows attackers to access underlying infrastructure, requiring an upgrade to the latest version.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:L/SI:L/SA:N/S:N/AU:Y/R:A/V:D/RE:L/U:Green`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Apr 2025
- **Updated:** 10 Apr 2025
- **Also known as:** GHSA-2c34-w9r8-qhww

## What is CVE-2025-22374?

CVE-2025-22374 is a medium-severity server-side request forgery vulnerability in Videx Inc. CyberAudit-Web, published on 10 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A Server-Side Request Forgery (SSRF) vulnerability was discovered in the videx-legacy-ssl web service of Videx’s CyberAudit-Web, affecting versions prior to 1.1.3. This vulnerability has been patched in versions after 1.1.3. Leaving this vulnerability unpatched could lead to unauthorized access to the underlying infrastructure.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-22374?


## How do I fix CVE-2025-22374?

No fix has been published for CVE-2025-22374 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-22374 being exploited?

There is no known exploitation of CVE-2025-22374 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-22374 and fix it if it is affected.

What it is: CVE-2025-22374 is a medium-severity server-side request forgery vulnerability in Videx Inc. CyberAudit-Web, published on 10 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-22374 in the wild and no public exploit code.

Affected product: Videx Inc. CyberAudit-Web. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-22374/ (Markdown: https://insights.sbomify.com/CVE-2025-22374/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-22374
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-22374
- OSV: https://osv.dev/vulnerability/CVE-2025-22374

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-22374/
Summaries are generated and may contain mistakes; the official description above is the record.
