CVE-2025-22445 Misleading UI for undefined admin console settings in Calls causes security confusion
Mattermost admins may misconfigure Calls security settings due to misleading UI, potentially leading to unintended security bypasses.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-22445?
CVE-2025-22445 is a low-severity vulnerability in Mattermost Mattermost Server, published on 9 Jan 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Mattermost versions 10.x <= 10.2 fail to accurately reflect missing settings, which allows confusion for admins regarding a Calls security-sensitive configuration via incorrect UI reporting.
Weakness: CWE-754
Which versions are affected by CVE-2025-22445?
8 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250102081831-64c566a8280b |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250102081831-64c566a8280b |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250102081831-64c566a8280b |
github.com/mattermost/mattermost/server/v8 Go | From 10.0 | 10.3.0 |
github.com/mattermost/mattermost/server/v8 Go | From 10.0 | 10.3.0 |
github.com/mattermost/mattermost-server Go | All versions | 10.3.0+incompatible |
2 more packages
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-22445?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20250102081831-64c566a8280b or 10.3.0.
Is CVE-2025-22445 being exploited?
There is no known exploitation of CVE-2025-22445 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-7rgp-4j56-fm79, GO-2025-3380.