CVE-2025-22449 Access control flaw for team admins allows unauthorized team additions
Team admins can bypass invite restrictions by making their team public, allowing unauthorized user additions to the team.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-22449?
CVE-2025-22449 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 9 Jan 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Mattermost versions 9.11.x <= 9.11.5 fail to enforce invite permissions, which allows team admins, with no permission to invite users to their team, to invite users by updating the "allow_open_invite" field via making their team public.
Weakness: CWE-863
Which versions are affected by CVE-2025-22449?
8 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250102081831-64c566a8280b |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250102081831-64c566a8280b |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250102081831-64c566a8280b |
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0 | 9.11.6 |
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0 | 9.11.6 |
github.com/mattermost/mattermost-server Go | From 9.11.0+incompatible | None |
2 more packages
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-22449?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20250102081831-64c566a8280b or 9.11.6.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-22449 being exploited?
There is no known exploitation of CVE-2025-22449 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-q8fg-cp3q-5jwm, GO-2025-3377.