CVE-2025-2256 Improper Validation of Specified Quantity in Input in GitLab

High 7.5 Published Updated

Unauthorized users can render GitLab unresponsive by sending multiple concurrent large SAML responses, requiring administrators to upgrade to patched versions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-2256?

CVE-2025-2256 is a high-severity denial of service vulnerability in Gitlab Gitlab, published on 12 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions from 7.12 before 18.1.6, 18.2 before 18.2.6, and 18.3 before 18.3.2 that could have allowed unauthorized users to render the GitLab instance unresponsive to legitimate users by sending multiple concurrent large SAML responses.

Weakness: CWE-1284

Which versions are affected by CVE-2025-2256?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 7.12.018.1.6, 18.2.6, 18.3.2

Products include Gitlab Gitlab.

How do I fix CVE-2025-2256?

Upgrade gitlab to a fixed version for your release line: 18.1.6, 18.2.6 or 18.3.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-2256 being exploited?

There is no known exploitation of CVE-2025-2256 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-2256, GHSA-m8q6-f6pj-j3mh.

Is CVE-2025-2256 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free