{"answers":{"affected":"2 open source packages ship an affected version, including golang and stdlib.","exploited":"There is no known exploitation of CVE-2025-22874 in the wild and no public exploit code.","fix":"Upgrade golang to 1.24.4 or later.","what":"CVE-2025-22874 is a high-severity vulnerability in Go standard library crypto/x509, published on 11 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-22874 and fix it if it is affected.\n\nWhat it is: CVE-2025-22874 is a high-severity vulnerability in Go standard library crypto/x509, published on 11 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-22874 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- golang (Bitnami): affected from 1.24.0-0; fixed in 1.24.4\n- stdlib (Go): affected from 1.24.0-0; fixed in 1.24.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-22874/ (Markdown: https://insights.sbomify.com/CVE-2025-22874/index.md)","id":"CVE-2025-22874","markdown":"https://insights.sbomify.com/CVE-2025-22874/index.md","name":"CVE-2025-22874","record":{"aliases":["AZL-63872","AZL-72104","AZL-78986","AZL-98865","BELL-CVE-2025-22874","BIT-golang-2025-22874","DEBIAN-CVE-2025-22874","ECHO-4e0e-8b9e-064d","GHSA-6f52-wpx2-hvf2","GO-2025-3749","MINI-2299-m92r-j6r5","MINI-2cqr-qgrj-h4w8","MINI-35p3-f9r2-qpq7","MINI-3ch4-fhqv-9fqv","MINI-3gfq-jx52-6g93","MINI-4r8x-56r6-px29","MINI-5hj2-vfpw-5m79","MINI-5r6w-965m-mc7v","MINI-5r84-89c4-2239","MINI-675h-5v2j-5f96","MINI-6qp7-96p2-29rp","MINI-7239-pr8h-52m2","MINI-784r-r4r3-rggx","MINI-78x4-37v9-cpr3","MINI-7c6q-h9h6-79ph","MINI-9ghh-c963-72vx","MINI-c2gq-48q3-pp8p","MINI-fprp-79xv-5765","MINI-fw3c-wwq7-3v4q","MINI-gj2g-6jmc-mgxp","MINI-h78p-hmx3-7fm4","MINI-hgxv-5282-m9m9","MINI-hq2r-xjf7-hhpf","MINI-j5f2-3mp8-j869","MINI-jhr3-f56f-v7p5","MINI-jxgq-j28c-pj38","MINI-mphc-823q-jwwh","MINI-p5rw-h67q-mmmg","MINI-pgmg-2f3g-jpjh","MINI-pm9c-p6x3-mg69","MINI-r9f8-x33v-cqr6","MINI-rp2p-2j67-jv2c","MINI-rph5-66vc-mg53","MINI-rvw2-q4hm-q3mg","MINI-vfhh-jx4j-cxhh","MINI-vwpv-fg4c-96gf","MINI-w6g9-r7p7-667q","MINI-wfx2-763v-v2vm","MINI-wx46-jhr4-j336","MINI-x3h8-59cr-2hm3","MINI-x877-68wf-p5jp","MINI-x88v-27r9-rg89","MINI-xgmc-675v-47q5","MINI-xhpw-mr86-w8ff","MINI-xqq8-fr72-jj52","MINI-xxm3-ccrm-38f2","UBUNTU-CVE-2025-22874","openSUSE-SU-2025:15251-1","openSUSE-SU-2025:15263-1","openSUSE-SU-2025:15379-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Go crypto/x509 library","requires_auth":"none","summary":"Attackers can bypass certificate policy validation in Go applications by using ExtKeyUsageAny, potentially accepting invalid certificates.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Go","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[],"description":"Calling Verify with a VerifyOptions.KeyUsages that contains ExtKeyUsageAny unintentionally disabledpolicy validation. This only affected certificate chains which contain policy graphs, which are rather uncommon.","ecosystems":["Bitnami","Go","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Usage of ExtKeyUsageAny disables policy validation in crypto/x509","id":"CVE-2025-22874","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"security_feature_bypass","year":"2025"},"n_packages":5,"n_references":4,"next":{"headline":"Heap-based Buffer Overflow in CNCSoft-G2","id":"CVE-2025-22880"},"packages":[{"ecosystem":"Bitnami","fixed":["1.24.4"],"introduced":["1.24.0-0"],"last_affected":[],"package":"golang","purl":"pkg:bitnami/golang","source":"BIT-golang-2025-22874"},{"ecosystem":"Go","fixed":["1.24.4"],"introduced":["1.24.0-0"],"last_affected":[],"package":"stdlib","purl":"pkg:golang/stdlib","source":"GO-2025-3749"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["20250721T052808Z-1.1"],"introduced":["0"],"last_affected":[],"package":"minio-client","purl":"pkg:rpm/opensuse/minio-client\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15379-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["3.11.4-1.1"],"introduced":["0"],"last_affected":[],"package":"nova","purl":"pkg:rpm/opensuse/nova\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15251-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["9.6.4-1.1"],"introduced":["0"],"last_affected":[],"package":"polaris","purl":"pkg:rpm/opensuse/polaris\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15263-1"}],"prev":{"headline":"Improper access to parent directory of root in os","id":"CVE-2025-22873"},"products":["crypto/x509"],"published":"2025-06-11","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-16","vendors":["Go standard library"]},"summary":"Attackers can bypass certificate policy validation in Go applications by using ExtKeyUsageAny, potentially accepting invalid certificates.","url":"https://insights.sbomify.com/CVE-2025-22874/"}