{"answers":{"affected":"1 open source package ship an affected version, including pgbouncer. It affects 2 products.","exploited":"There is no known exploitation of CVE-2025-2291 in the wild and no public exploit code.","fix":"Upgrade pgbouncer to 1.24.1 or later.","what":"CVE-2025-2291 is a high-severity authentication bypass vulnerability in Debian Debian Linux, published on 16 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-2291 and fix it if it is affected.\n\nWhat it is: CVE-2025-2291 is a high-severity authentication bypass vulnerability in Debian Debian Linux, published on 16 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-2291 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pgbouncer (Bitnami): affected all versions; fixed in 1.24.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-2291/ (Markdown: https://insights.sbomify.com/CVE-2025-2291/index.md)","id":"CVE-2025-2291","markdown":"https://insights.sbomify.com/CVE-2025-2291/index.md","name":"CVE-2025-2291","record":{"aliases":["AZL-60437","AZL-60438","BIT-pgbouncer-2025-2291","DEBIAN-CVE-2025-2291","GHSA-qj9w-64mv-p2fw","UBUNTU-CVE-2025-2291"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"PostgreSQL connection pooler","requires_auth":"none","summary":"Attackers can log in using expired passwords because PgBouncer's default authentication query ignores PostgreSQL password expiration settings.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"PostgreSQL","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"pgbouncer","vendor":"pgbouncer"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-324","name":"Use of a Key Past its Expiration Date"}],"description":"Password can be used past expiry in PgBouncer due to auth_query not taking into account Postgres its VALID UNTIL value, which allows an attacker to log in with an already expired password","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PgBouncer default auth_query does not take Postgres password expiry into account","id":"CVE-2025-2291","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"auth_bypass","year":"2025"},"n_packages":1,"n_references":1,"next":{"headline":"Xorcom CompletePBX \u003c= 5.2.35 Authenticated File Disclosure","id":"CVE-2025-2292"},"packages":[{"ecosystem":"Bitnami","fixed":["1.24.1"],"introduced":["0"],"last_affected":[],"package":"pgbouncer","purl":"pkg:bitnami/pgbouncer","source":"BIT-pgbouncer-2025-2291"}],"prev":{"headline":"LifterLMS \u003c= 8.0.1 - Missing Authorization to Unauthenticated Post Trashing","id":"CVE-2025-2290"},"products":["PgBouncer"],"published":"2025-04-16","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["n/a"]},"summary":"Attackers can log in using expired passwords because PgBouncer's default authentication query ignores PostgreSQL password expiration settings.","url":"https://insights.sbomify.com/CVE-2025-2291/"}