CVE-2025-23015 Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions
A user with MODIFY permission on all keyspaces can escalate privileges to superuser via unsafe actions in Apache Cassandra.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-23015?
CVE-2025-23015 is a high-severity vulnerability in Apache Cassandra, published on 4 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches.
This issue affects Apache Cassandra through 3.0.30, 3.11.17, 4.0.15, 4.1.7, 5.0.2.
Users are recommended to upgrade to versions 3.0.31, 3.11.18, 4.0.16, 4.1.8, 5.0.3, which fixes the issue.
Weakness: CWE-267
Which versions are affected by CVE-2025-23015?
11 open source packages ship an affected version, including org.apache.cassandra:cassandra-all and cassandra. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.cassandra:cassandra-all Maven | All versions | 3.0.31 |
org.apache.cassandra:cassandra-all Maven | All versions | 3.0.31 |
org.apache.cassandra:cassandra-all Maven | From 3.1 | 3.11.18 |
org.apache.cassandra:cassandra-all Maven | From 3.1 | 3.11.18 |
org.apache.cassandra:cassandra-all Maven | From 4.0-alpha1 | 4.0.16 |
org.apache.cassandra:cassandra-all Maven | From 4.0-alpha1 | 4.0.16 |
5 more packages
org.apache.cassandra:cassandra-all Maven | From 4.1-alpha1 | 4.1.8 |
org.apache.cassandra:cassandra-all Maven | From 4.1-alpha1 | 4.1.8 |
org.apache.cassandra:cassandra-all Maven | From 5.0-alpha1 | 5.0.3 |
org.apache.cassandra:cassandra-all Maven | From 5.0-alpha1 | 5.0.3 |
cassandra Bitnami | From 3.0.0 | 3.0.31, 3.11.18, 4.0.16, 4.1.8, 5.0.3 |
Products include Apache Cassandra.
How do I fix CVE-2025-23015?
Upgrade org.apache.cassandra:cassandra-all to a fixed version for your release line: 3.0.31, 3.11.18, 4.0.16 or 4.1.8.
Is CVE-2025-23015 being exploited?
There is no known exploitation of CVE-2025-23015 in the wild and no public exploit code.
Other vulnerabilities in Apache Cassandra
- CVE-2016-3427 Oracle Java SE and JRockit Unspecified
- CVE-2018-8016 Missing Authentication for Critical Function in Apache Cassandra
- CVE-2021-44521 Remote code execution for scripted UDFs
- CVE-2026-27314 Apache Cassandra: Privilege escalation via ADD IDENTITY authorization bypass
- CVE-2025-26467 Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions (4.0.16 only)
Sources
Also known as AZL-56436, AZL-56443, BIT-cassandra-2025-23015, CLEANSTART-2026-UO57985, ECHO-0954-f6fc-045e, GHSA-wmcc-9vch-jmx4 and 5 more.