# CVE-2025-23020: Kwik hash collision vulnerability

> Remote attackers can cause excessive CPU load on servers using the Kwik library by exploiting a hash collision vulnerability in connection management.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Feb 2025
- **Updated:** 20 Feb 2025
- **Also known as:** GHSA-9f57-9rhg-4hvm

## What is CVE-2025-23020?

CVE-2025-23020 is a medium-severity denial of service vulnerability in ptrd Kwik, published on 20 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Kwik before 0.10.1. A hash collision vulnerability (in the hash table used to manage connections) allows remote attackers to cause a considerable CPU load on the server (a Hash DoS attack) by initiating connections with colliding Source Connection IDs (SCIDs).

Weakness: CWE-407 (Inefficient Algorithmic Complexity)

## Which versions are affected by CVE-2025-23020?

2 open source packages ship an affected version, including tech.kwik:kwik.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tech.kwik:kwik` | Maven | All versions | 0.10.1 |
| `tech.kwik:kwik` | Maven | All versions | 0.10.1 |

## How do I fix CVE-2025-23020?

Upgrade tech.kwik:kwik to 0.10.1 or later.

## Is CVE-2025-23020 being exploited?

There is no known exploitation of CVE-2025-23020 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-23020 and fix it if it is affected.

What it is: CVE-2025-23020 is a medium-severity denial of service vulnerability in ptrd Kwik, published on 20 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-23020 in the wild and no public exploit code.

Affected packages and fixed versions:
- tech.kwik:kwik (Maven): affected all versions; fixed in 0.10.1
- tech.kwik:kwik (Maven): affected all versions; fixed in 0.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-23020/ (Markdown: https://insights.sbomify.com/CVE-2025-23020/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-23020
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-23020
- OSV: https://osv.dev/vulnerability/CVE-2025-23020

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-23020/
Summaries are generated and may contain mistakes; the official description above is the record.
