# CVE-2025-23025: Privilege escalation (PR) through realtime WYSIWYG editing in XWiki

> A user with edit rights can escalate privileges to script or programming rights by injecting macros into realtime WYSIWYG editing sessions.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Jan 2025
- **Updated:** 15 Jan 2025
- **Also known as:** GHSA-rmm7-r7wr-xpfg

## What is CVE-2025-23025?

CVE-2025-23025 is a critical vulnerability in Xwiki Xwiki, published on 14 Jan 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. NOTE: The Realtime WYSIWYG Editor extension was **experimental**, and thus **not recommended**, in the versions affected by this vulnerability. It has become enabled by default, and thus recommended, starting with XWiki 16.9.0. A user with only **edit right** can join a realtime editing session where others, that where already there or that may join later, have **script** or **programming** access rights. This user can then insert **script rendering macros** that are executed for those users in the realtime session that have script or programming rights. The inserted scripts can be used to gain more access rights. This vulnerability has been patched in XWiki 15.10.2, 16.4.1 and 16.6.0-rc-1. Users are advised to upgrade. Users unable to upgrade may either disable the realtime WYSIWYG editing by disabling the ``xwiki-realtime`` CKEditor plugin from the WYSIWYG editor administration section or uninstall the Realtime WYSIWYG Editorextension (org.xwiki.platform:xwiki-platform-realtime-wysiwyg-ui).

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2025-23025?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-realtime-wysiwyg-ui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-realtime-wysiwyg-ui` | Maven | From 13.9-rc-1 | 15.10.12 |
| `org.xwiki.platform:xwiki-platform-realtime-wysiwyg-ui` | Maven | From 13.9-rc-1 | 15.10.12 |
| `org.xwiki.platform:xwiki-platform-realtime-wysiwyg-ui` | Maven | From 16.0.0-rc-1 | 16.4.1 |
| `org.xwiki.platform:xwiki-platform-realtime-wysiwyg-ui` | Maven | From 16.0.0-rc-1 | 16.4.1 |
| `org.xwiki.platform:xwiki-platform-realtime-wysiwyg-ui` | Maven | From 16.5.0-rc-1 | 16.6.0-rc-1 |
| `org.xwiki.platform:xwiki-platform-realtime-wysiwyg-ui` | Maven | From 16.5.0-rc-1 | 16.6.0-rc-1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2025-23025?

Upgrade org.xwiki.platform:xwiki-platform-realtime-wysiwyg-ui to a fixed version for your release line: 15.10.12, 16.4.1 or 16.6.0-rc-1.

## Is CVE-2025-23025 being exploited?

There is no known exploitation of CVE-2025-23025 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-23025 and fix it if it is affected.

What it is: CVE-2025-23025 is a critical vulnerability in Xwiki Xwiki, published on 14 Jan 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-23025 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-realtime-wysiwyg-ui (Maven): affected from 13.9-rc-1; fixed in 15.10.12
- org.xwiki.platform:xwiki-platform-realtime-wysiwyg-ui (Maven): affected from 13.9-rc-1; fixed in 15.10.12
- org.xwiki.platform:xwiki-platform-realtime-wysiwyg-ui (Maven): affected from 16.0.0-rc-1; fixed in 16.4.1
- org.xwiki.platform:xwiki-platform-realtime-wysiwyg-ui (Maven): affected from 16.0.0-rc-1; fixed in 16.4.1
- org.xwiki.platform:xwiki-platform-realtime-wysiwyg-ui (Maven): affected from 16.5.0-rc-1; fixed in 16.6.0-rc-1
- org.xwiki.platform:xwiki-platform-realtime-wysiwyg-ui (Maven): affected from 16.5.0-rc-1; fixed in 16.6.0-rc-1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-23025/ (Markdown: https://insights.sbomify.com/CVE-2025-23025/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-23025
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-23025
- OSV: https://osv.dev/vulnerability/CVE-2025-23025

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-23025/
Summaries are generated and may contain mistakes; the official description above is the record.
