{"answers":{"affected":"4 open source packages ship an affected version, including gg.jte:jte and gg.jte:jte-runtime.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-23026 exists.","fix":"Upgrade gg.jte:jte to 3.1.16 or later.","what":"CVE-2025-23026 is a medium-severity cross-site scripting vulnerability in casid jte, published on 13 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-23026 and fix it if it is affected.\n\nWhat it is: CVE-2025-23026 is a medium-severity cross-site scripting vulnerability in casid jte, published on 13 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-23026 exists.\n\nAffected packages and fixed versions:\n- gg.jte:jte (Maven): affected all versions; fixed in 3.1.16\n- gg.jte:jte (Maven): affected all versions; fixed in 3.1.16\n- gg.jte:jte-runtime (Maven): affected all versions; fixed in 3.1.16\n- gg.jte:jte-runtime (Maven): affected all versions; fixed in 3.1.16\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-23026/ (Markdown: https://insights.sbomify.com/CVE-2025-23026/index.md)","id":"CVE-2025-23026","markdown":"https://insights.sbomify.com/CVE-2025-23026/index.md","name":"CVE-2025-23026","record":{"aliases":["GHSA-vh22-6c6h-rm8q"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Java template engine","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript via unescaped backticks in HTML templates, affecting Java and Kotlin applications using the jte library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-150","name":"Improper Neutralization of Escape, Meta, or Control Sequences"}],"description":"jte (Java Template Engine) is a secure and lightweight template engine for Java and Kotlin. In affected versions Jte HTML templates with `script` tags or script attributes that include a Javascript template string (backticks) are subject to XSS. The `javaScriptBlock` and `javaScriptAttribute` methods in the `Escape` class do not escape backticks, which are used for Javascript template strings. Dollar signs in template strings should also be escaped as well to prevent undesired interpolation. HTML templates rendered by Jte's `OwaspHtmlTemplateOutput` in versions less than or equal to `3.1.15` with `script` tags or script attributes that contain Javascript template strings (backticks) are vulnerable. Users are advised to upgrade to version 3.1.16 or later to resolve this issue. There are no known workarounds for this vulnerability.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"HTML templates containing Javascript template strings are subject to XSS in jte","id":"CVE-2025-23026","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":4,"n_references":3,"next":{"headline":"BASEHUB_TOKEN commited in next-forge","id":"CVE-2025-23027"},"packages":[{"ecosystem":"Maven","fixed":["3.1.16"],"introduced":["0"],"last_affected":[],"package":"gg.jte:jte","purl":null,"source":"GHSA-vh22-6c6h-rm8q"},{"ecosystem":"Maven","fixed":["3.1.16"],"introduced":["0"],"last_affected":[],"package":"gg.jte:jte","purl":"pkg:maven/gg.jte/jte","source":"GHSA-vh22-6c6h-rm8q"},{"ecosystem":"Maven","fixed":["3.1.16"],"introduced":["0"],"last_affected":[],"package":"gg.jte:jte-runtime","purl":null,"source":"GHSA-vh22-6c6h-rm8q"},{"ecosystem":"Maven","fixed":["3.1.16"],"introduced":["0"],"last_affected":[],"package":"gg.jte:jte-runtime","purl":"pkg:maven/gg.jte/jte-runtime","source":"GHSA-vh22-6c6h-rm8q"}],"prev":{"headline":"Privilege escalation (PR) through realtime WYSIWYG editing in XWiki","id":"CVE-2025-23025"},"products":["jte"],"published":"2025-01-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-13","vendors":["casid"]},"summary":"Attackers can execute arbitrary JavaScript via unescaped backticks in HTML templates, affecting Java and Kotlin applications using the jte library.","url":"https://insights.sbomify.com/CVE-2025-23026/"}