CVE-2025-23028 DoS in Cilium agent DNS proxy from crafted DNS responses
An attacker can crash Cilium agents by sending crafted DNS responses, disrupting DNS-based policies in Kubernetes clusters using DNS proxying.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-23028?
CVE-2025-23028 is a medium-severity denial of service vulnerability in cilium, published on 22 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Cilium is a networking, observability, and security solution with an eBPF-based dataplane. A denial of service vulnerability affects versions 1.14.0 through 1.14.7, 1.15.0 through 1.15.11, and 1.16.0 through 1.16.4. In a Kubernetes cluster where Cilium is configured to proxy DNS traffic, an attacker can crash Cilium agents by sending a crafted DNS response to workloads from outside the cluster. For traffic that is allowed but without using DNS-based policy, the dataplane will continue to pass traffic as configured at the time of the DoS. For workloads that have DNS-based policy configured, existing connections may continue to operate, and new connections made without relying on DNS resolution may continue to be established, but new connections which rely on DNS resolution may be disrupted. Any configuration changes that affect the impacted agent may not be applied until the agent is able to restart. This issue is fixed in Cilium v1.14.18, v1.15.12, and v1.16.5. No known workarounds are available.
Weakness: CWE-770
Which versions are affected by CVE-2025-23028?
10 open source packages ship an affected version, including github.com/cilium/cilium, cilium and cilium-operator. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/cilium/cilium Go | From 1.14.0 | 1.14.18, 1.15.12, 1.16.5 |
github.com/cilium/cilium Go | From 1.14.0 | 1.14.18 |
github.com/cilium/cilium Go | From 1.14.0 | 1.14.18 |
github.com/cilium/cilium Go | From 1.15.0 | 1.15.12 |
github.com/cilium/cilium Go | From 1.15.0 | 1.15.12 |
github.com/cilium/cilium Go | From 1.16.0 | 1.16.5 |
4 more packages
github.com/cilium/cilium Go | From 1.16.0 | 1.16.5 |
cilium Bitnami | From 1.15.4 | 1.16.5 |
cilium-operator Bitnami | From 1.15.4 | 1.16.5 |
hubble-relay Bitnami | From 1.14.0 | 1.16.5 |
Products include Cilium Cilium.
How do I fix CVE-2025-23028?
Upgrade github.com/cilium/cilium to a fixed version for your release line: 1.14.18, 1.15.12 or 1.16.5.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-23028 being exploited?
There is no known exploitation of CVE-2025-23028 in the wild and no public exploit code.
Other vulnerabilities in cilium
- CVE-2026-49445 Cilium: Sensitive information disclosure and cluster disruption via local Envoy admin socket access
- CVE-2022-29178 Incorrect Default Permissions in Cilium
- CVE-2024-28860 Insecure IPsec transport encryption in Cilium
- CVE-2026-41520 Cillium exposes sensitive information included in the cilium-bugtool debug archive
- CVE-2024-37307 Cilium leaks sensitive information in cilium-bugtool
Sources
Also known as BIT-cilium-2025-23028, BIT-cilium-operator-2025-23028, BIT-hubble-relay-2025-23028, GHSA-9m5p-c77c-f9j7, GO-2025-3415.