# CVE-2025-23028: DoS in Cilium agent DNS proxy from crafted DNS responses

> An attacker can crash Cilium agents by sending crafted DNS responses, disrupting DNS-based policies in Kubernetes clusters using DNS proxying.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jan 2025
- **Updated:** 18 Feb 2025
- **Also known as:** BIT-cilium-2025-23028, BIT-cilium-operator-2025-23028, BIT-hubble-relay-2025-23028, GHSA-9m5p-c77c-f9j7, GO-2025-3415

## What is CVE-2025-23028?

CVE-2025-23028 is a medium-severity denial of service vulnerability in cilium, published on 22 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Cilium is a networking, observability, and security solution with an eBPF-based dataplane. A denial of service vulnerability affects versions 1.14.0 through 1.14.7, 1.15.0 through 1.15.11, and 1.16.0 through 1.16.4. In a Kubernetes cluster where Cilium is configured to proxy DNS traffic, an attacker can crash Cilium agents by sending a crafted DNS response to workloads from outside the cluster. For traffic that is allowed but without using DNS-based policy, the dataplane will continue to pass traffic as configured at the time of the DoS. For workloads that have DNS-based policy configured, existing connections may continue to operate, and new connections made without relying on DNS resolution may continue to be established, but new connections which rely on DNS resolution may be disrupted. Any configuration changes that affect the impacted agent may not be applied until the agent is able to restart. This issue is fixed in Cilium v1.14.18, v1.15.12, and v1.16.5. No known workarounds are available.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-23028?

10 open source packages ship an affected version, including github.com/cilium/cilium, cilium and cilium-operator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cilium/cilium` | Go | From 1.14.0 | 1.14.18, 1.15.12, 1.16.5 |
| `github.com/cilium/cilium` | Go | From 1.14.0 | 1.14.18 |
| `github.com/cilium/cilium` | Go | From 1.14.0 | 1.14.18 |
| `github.com/cilium/cilium` | Go | From 1.15.0 | 1.15.12 |
| `github.com/cilium/cilium` | Go | From 1.15.0 | 1.15.12 |
| `github.com/cilium/cilium` | Go | From 1.16.0 | 1.16.5 |
| `github.com/cilium/cilium` | Go | From 1.16.0 | 1.16.5 |
| `cilium` | Bitnami | From 1.15.4 | 1.16.5 |
| `cilium-operator` | Bitnami | From 1.15.4 | 1.16.5 |
| `hubble-relay` | Bitnami | From 1.14.0 | 1.16.5 |

Products: Cilium Cilium.

## How do I fix CVE-2025-23028?

Upgrade github.com/cilium/cilium to a fixed version for your release line: 1.14.18, 1.15.12 or 1.16.5.

## Is CVE-2025-23028 being exploited?

There is no known exploitation of CVE-2025-23028 in the wild and no public exploit code.

## Other vulnerabilities in cilium

- [CVE-2026-49445](https://insights.sbomify.com/CVE-2026-49445/): Cilium: Sensitive information disclosure and cluster disruption via local Envoy admin socket access (critical 9.2)
- [CVE-2022-29178](https://insights.sbomify.com/CVE-2022-29178/): Incorrect Default Permissions in Cilium (high 8.8)
- [CVE-2024-28860](https://insights.sbomify.com/CVE-2024-28860/): Insecure IPsec transport encryption in Cilium (high 8.0)
- [CVE-2026-41520](https://insights.sbomify.com/CVE-2026-41520/): Cillium exposes sensitive information included in the cilium-bugtool debug archive (high 7.9)
- [CVE-2024-37307](https://insights.sbomify.com/CVE-2024-37307/): Cilium leaks sensitive information in cilium-bugtool (high 7.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-23028 and fix it if it is affected.

What it is: CVE-2025-23028 is a medium-severity denial of service vulnerability in cilium, published on 22 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-23028 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/cilium/cilium (Go): affected from 1.14.0; fixed in 1.14.18, 1.15.12, 1.16.5
- github.com/cilium/cilium (Go): affected from 1.14.0; fixed in 1.14.18
- github.com/cilium/cilium (Go): affected from 1.14.0; fixed in 1.14.18
- github.com/cilium/cilium (Go): affected from 1.15.0; fixed in 1.15.12
- github.com/cilium/cilium (Go): affected from 1.15.0; fixed in 1.15.12
- github.com/cilium/cilium (Go): affected from 1.16.0; fixed in 1.16.5
- github.com/cilium/cilium (Go): affected from 1.16.0; fixed in 1.16.5
- cilium (Bitnami): affected from 1.15.4; fixed in 1.16.5
- cilium-operator (Bitnami): affected from 1.15.4; fixed in 1.16.5
- hubble-relay (Bitnami): affected from 1.14.0; fixed in 1.16.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-23028/ (Markdown: https://insights.sbomify.com/CVE-2025-23028/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-23028
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-23028
- OSV: https://osv.dev/vulnerability/CVE-2025-23028

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-23028/
Summaries are generated and may contain mistakes; the official description above is the record.
