# CVE-2025-2304: Camaleon CMS Privilege Escalation

> Attackers can escalate privileges via mass assignment in the password update method due to unfiltered parameters.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Mar 2025
- **Updated:** 17 Mar 2025
- **Also known as:** GHSA-rp28-mvq3-wf8j

## What is CVE-2025-2304?

CVE-2025-2304 is a critical vulnerability in owen2345 camaleon-cms, published on 14 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A Privilege Escalation through a Mass Assignment exists in Camaleon CMS

When a user wishes to change his password, the 'updated_ajax' method of the UsersController is called. The vulnerability stems from the use of the dangerous permit! method, which allows all parameters to pass through without any filtering.

Weakness: CWE-915 (Improperly Controlled Modification of Dynamically-Determined Object Attributes)

## Which versions are affected by CVE-2025-2304?

2 open source packages ship an affected version, including camaleon_cms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `camaleon_cms` | RubyGems | All versions | 2.9.1 |
| `camaleon_cms` | RubyGems | All versions | 2.9.1 |

## How do I fix CVE-2025-2304?

Upgrade camaleon_cms to 2.9.1 or later.

## Is CVE-2025-2304 being exploited?

There is no known exploitation of CVE-2025-2304 in the wild and no public exploit code.

Public exploit code:

- Authenticated privilege escalation in Camaleon CMS v2.9.0 via improper parameter handling in the updated_ajax endpoint. (github_poc): https://github.com/Alien0ne/CVE-2025-2304
- Python script to exploit Privilege Escalation in Camaleon CMS. (github_poc): https://github.com/predyy/CVE-2025-2304
- CVE-2025-2304 POC (github_poc): https://github.com/whiteov3rflow/CVE-2025-2304-POC
- Proof-of-concept for CVE-2025-2304 — critical (CVSS 9.4) mass-assignment privilege escalation in Camaleon CMS. (github_poc): https://github.com/d3vn0mi/CVE-2025-2304-POC
- This Python script exploits a critical mass assignment vulnerability in Camaleon CMS version 2.9.0, allowing any registered user to escalate their privileges to administrator. (github_poc): https://github.com/CsuriBird/CVE-2025-2304
- Privilege escalation vulnerability in Camaleon CMS < 2.9.1. (github_poc): https://github.com/estebanzarate/CVE-2025-2304-Camaleon-CMS-Mass-Assignment-Privilege-Escalation-PoC

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-2304 and fix it if it is affected.

What it is: CVE-2025-2304 is a critical vulnerability in owen2345 camaleon-cms, published on 14 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-2304 in the wild and no public exploit code.

Affected packages and fixed versions:
- camaleon_cms (RubyGems): affected all versions; fixed in 2.9.1
- camaleon_cms (RubyGems): affected all versions; fixed in 2.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-2304/ (Markdown: https://insights.sbomify.com/CVE-2025-2304/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-2304
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-2304
- OSV: https://osv.dev/vulnerability/CVE-2025-2304

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-2304/
Summaries are generated and may contain mistakes; the official description above is the record.
