{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-23040 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-23040 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-23040 is a medium-severity vulnerability in desktop, published on 15 Jan 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-23040 and fix it if it is affected.\n\nWhat it is: CVE-2025-23040 is a medium-severity vulnerability in desktop, published on 15 Jan 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-23040 in the wild and no public exploit code.\n\nAffected product: desktop. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-23040/ (Markdown: https://insights.sbomify.com/CVE-2025-23040/index.md)","id":"CVE-2025-23040","markdown":"https://insights.sbomify.com/CVE-2025-23040/index.md","name":"CVE-2025-23040","record":{"aliases":["GHSA-36mm-rh9q-cpqq"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"GitHub Desktop","requires_auth":"low_privilege","summary":"Attackers can exfiltrate user credentials by tricking them into cloning a repository with a maliciously crafted remote URL in GitHub Desktop.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.6,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-522","name":"Insufficiently Protected Credentials"}],"description":"GitHub Desktop is an open-source Electron-based GitHub app designed for git development. An attacker convincing a user to clone a repository directly or through a submodule can allow the attacker access to the user's credentials through the use of maliciously crafted remote URL. GitHub Desktop relies on Git to perform all network related operations (such as cloning, fetching, and pushing). When a user attempts to clone a repository GitHub Desktop will invoke `git clone` and when Git encounters a remote which requires authentication it will request the credentials for that remote host from GitHub Desktop using the git-credential protocol. Using a maliciously crafted URL it's possible to cause the credential request coming from Git to be misinterpreted by Github Desktop such that it will send credentials for a different host than the host that Git is currently communicating with thereby allowing for secret exfiltration. GitHub username and OAuth token, or credentials for other Git remote hosts stored in GitHub Desktop could be improperly transmitted to an unrelated host. Users should update to GitHub Desktop 3.4.12 or greater which fixes this vulnerability. Users who suspect they may be affected should revoke any relevant credentials.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":"2025-01-31","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-01-31T21:27:42Z","kind":"github_poc","ref":"https://github.com/GabrieleDattile/CVE-2025-23040","stars":0,"title":null}],"tier":"poc_unverified"},"has_fix":false,"headline":"Maliciously crafted remote URLs could lead to credential leak in GitHub Desktop","id":"CVE-2025-23040","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"information_disclosure","year":"2025"},"n_packages":0,"n_references":3,"next":{"headline":"Short and Long Answer Fields Are Not Validated Server-Side For Maximum Length in Umbraco.Forms","id":"CVE-2025-23041"},"packages":[],"prev":{"headline":"Cross Site Scripting on URL decode Tooltip in Caido","id":"CVE-2025-23039"},"products":["desktop"],"published":"2025-01-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-01-15","vendors":["desktop"]},"summary":"Attackers can exfiltrate user credentials by tricking them into cloning a repository with a maliciously crafted remote URL in GitHub Desktop.","url":"https://insights.sbomify.com/CVE-2025-23040/"}