# CVE-2025-23042: Gradio Blocked Path ACL Bypass Vulnerability

> Attackers can bypass file access restrictions by altering path case on case-insensitive systems, exposing sensitive files in Gradio applications.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jan 2025
- **Updated:** 12 Feb 2025
- **Also known as:** GHSA-j2jg-fq62-7c3h, PYSEC-2025-118

## What is CVE-2025-23042?

CVE-2025-23042 is a high-severity path traversal vulnerability in Gradio Project Gradio, published on 14 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Gradio is an open-source Python package that allows quick building of demos and web application for machine learning models, API, or any arbitrary Python function. Gradio's Access Control List (ACL) for file paths can be bypassed by altering the letter case of a blocked file or directory path. This vulnerability arises due to the lack of case normalization in the file path validation logic. On case-insensitive file systems, such as those used by Windows and macOS, this flaw enables attackers to circumvent security restrictions and access sensitive files that should be protected. This issue can lead to unauthorized data access, exposing sensitive information and undermining the integrity of Gradio's security model. Given Gradio's popularity for building web applications, particularly in machine learning and AI, this vulnerability may pose a substantial threat if exploited in production environments. This issue has been addressed in release version 5.6.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2025-23042?

3 open source packages ship an affected version, including gradio. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gradio` | PyPI | All versions | 5.11.0 |
| `gradio` | PyPI | All versions | 5.11.0 |
| `gradio` | PyPI | All versions | 5.6.0 |

Products: Gradio Project Gradio.

## How do I fix CVE-2025-23042?

Upgrade gradio to a fixed version for your release line: 5.11.0 or 5.6.0.

## Is CVE-2025-23042 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-23042 exists.

## Other vulnerabilities in Gradio Project Gradio

- [CVE-2024-39236](https://insights.sbomify.com/CVE-2024-39236/): Withdrawn Advisory: Gradio was discovered to contain a code injection vulnerability via the component /gradio/component_meta.py (critical 9.8)
- [CVE-2023-6572](https://insights.sbomify.com/CVE-2023-6572/): Command Injection in gradio-app/gradio (critical 9.6)
- [CVE-2022-24770](https://insights.sbomify.com/CVE-2022-24770/): Improper Neutralization of Formula Elements in a CSV File in Gradio Flagging (high 8.8)
- [CVE-2026-49119](https://insights.sbomify.com/CVE-2026-49119/): Gradio < 6.16.0 Path Traversal via FileExplorer.preprocess() (high 8.7)
- [CVE-2024-4325](https://insights.sbomify.com/CVE-2024-4325/): Server-Side Request Forgery (SSRF) in gradio-app/gradio (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-23042 and fix it if it is affected.

What it is: CVE-2025-23042 is a high-severity path traversal vulnerability in Gradio Project Gradio, published on 14 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-23042 exists.

Affected packages and fixed versions:
- gradio (PyPI): affected all versions; fixed in 5.11.0
- gradio (PyPI): affected all versions; fixed in 5.11.0
- gradio (PyPI): affected all versions; fixed in 5.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-23042/ (Markdown: https://insights.sbomify.com/CVE-2025-23042/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-23042
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-23042
- OSV: https://osv.dev/vulnerability/CVE-2025-23042

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-23042/
Summaries are generated and may contain mistakes; the official description above is the record.
