CVE-2025-23047 Cilium vulnerable to information leakage via insecure default Hubble UI CORS header
Insecure CORS headers in Hubble UI allow attackers to leak Kubernetes cluster configuration details if a victim visits a malicious page.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-23047?
CVE-2025-23047 is a medium-severity vulnerability in cilium, published on 22 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cilium is a networking, observability, and security solution with an eBPF-based dataplane. An insecure default `Access-Control-Allow-Origin` header value could lead to sensitive data exposure for users of Cilium versions 1.14.0 through 1.14.7, 1.15.0 through 1.15.11, and 1.16.0 through 1.16.4 who deploy Hubble UI using either Cilium CLI or via the Cilium Helm chart. A user with access to a Hubble UI instance affected by this issue could leak configuration details about the Kubernetes cluster which Hubble UI is monitoring, including node names, IP addresses, and other metadata about workloads and the cluster networking configuration. In order for this vulnerability to be exploited, a victim would have to first visit a malicious page. This issue is fixed in Cilium v1.14.18, v1.15.12, and v1.16.5. As a workaround, users who deploy Hubble UI using the Cilium Helm chart directly can remove the CORS headers from the Helm template as shown in the patch from commit a3489f190ba6e87b5336ee685fb6c80b1270d06d.
Weakness: CWE-200
Which versions are affected by CVE-2025-23047?
10 open source packages ship an affected version, including github.com/cilium/cilium, cilium and cilium-operator. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/cilium/cilium Go | From 1.14.0 | 1.14.19, 1.15.13, 1.16.6 |
github.com/cilium/cilium Go | From 1.14.0 | 1.14.19 |
github.com/cilium/cilium Go | From 1.14.0 | 1.14.19 |
github.com/cilium/cilium Go | From 1.15.0 | 1.15.13 |
github.com/cilium/cilium Go | From 1.15.0 | 1.15.13 |
github.com/cilium/cilium Go | From 1.16.0 | 1.16.6 |
4 more packages
github.com/cilium/cilium Go | From 1.16.0 | 1.16.6 |
cilium Bitnami | From 1.14.0 | 1.16.5 |
cilium-operator Bitnami | From 1.15.4 | 1.16.5 |
hubble-relay Bitnami | From 1.14.0 | 1.16.5 |
Products include Cilium Cilium.
How do I fix CVE-2025-23047?
Upgrade github.com/cilium/cilium to a fixed version for your release line: 1.14.19, 1.15.13 or 1.16.6.
Is CVE-2025-23047 being exploited?
There is no known exploitation of CVE-2025-23047 in the wild and no public exploit code.
Other vulnerabilities in cilium
- CVE-2026-49445 Cilium: Sensitive information disclosure and cluster disruption via local Envoy admin socket access
- CVE-2022-29178 Incorrect Default Permissions in Cilium
- CVE-2024-28860 Insecure IPsec transport encryption in Cilium
- CVE-2026-41520 Cillium exposes sensitive information included in the cilium-bugtool debug archive
- CVE-2024-37307 Cilium leaks sensitive information in cilium-bugtool
Sources
Also known as BIT-cilium-2025-23047, BIT-cilium-operator-2025-23047, BIT-hubble-relay-2025-23047, GHSA-h78m-j95m-5356, GO-2025-3416.