# CVE-2025-23047: Cilium vulnerable to information leakage via insecure default Hubble UI CORS header

> Insecure CORS headers in Hubble UI allow attackers to leak Kubernetes cluster configuration details if a victim visits a malicious page.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Jan 2025
- **Updated:** 12 Feb 2025
- **Also known as:** BIT-cilium-2025-23047, BIT-cilium-operator-2025-23047, BIT-hubble-relay-2025-23047, GHSA-h78m-j95m-5356, GO-2025-3416

## What is CVE-2025-23047?

CVE-2025-23047 is a medium-severity vulnerability in cilium, published on 22 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cilium is a networking, observability, and security solution with an eBPF-based dataplane. An insecure default `Access-Control-Allow-Origin` header value could lead to sensitive data exposure for users of Cilium versions 1.14.0 through 1.14.7, 1.15.0 through 1.15.11, and 1.16.0 through 1.16.4 who deploy Hubble UI using either Cilium CLI or via the Cilium Helm chart. A user with access to a Hubble UI instance affected by this issue could leak configuration details about the Kubernetes cluster which Hubble UI is monitoring, including node names, IP addresses, and other metadata about workloads and the cluster networking configuration. In order for this vulnerability to be exploited, a victim would have to first visit a malicious page. This issue is fixed in Cilium v1.14.18, v1.15.12, and v1.16.5. As a workaround, users who deploy Hubble UI using the Cilium Helm chart directly can remove the CORS headers from the Helm template as shown in the patch from commit a3489f190ba6e87b5336ee685fb6c80b1270d06d.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-23047?

10 open source packages ship an affected version, including github.com/cilium/cilium, cilium and cilium-operator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cilium/cilium` | Go | From 1.14.0 | 1.14.19, 1.15.13, 1.16.6 |
| `github.com/cilium/cilium` | Go | From 1.14.0 | 1.14.19 |
| `github.com/cilium/cilium` | Go | From 1.14.0 | 1.14.19 |
| `github.com/cilium/cilium` | Go | From 1.15.0 | 1.15.13 |
| `github.com/cilium/cilium` | Go | From 1.15.0 | 1.15.13 |
| `github.com/cilium/cilium` | Go | From 1.16.0 | 1.16.6 |
| `github.com/cilium/cilium` | Go | From 1.16.0 | 1.16.6 |
| `cilium` | Bitnami | From 1.14.0 | 1.16.5 |
| `cilium-operator` | Bitnami | From 1.15.4 | 1.16.5 |
| `hubble-relay` | Bitnami | From 1.14.0 | 1.16.5 |

Products: Cilium Cilium.

## How do I fix CVE-2025-23047?

Upgrade github.com/cilium/cilium to a fixed version for your release line: 1.14.19, 1.15.13 or 1.16.6.

## Is CVE-2025-23047 being exploited?

There is no known exploitation of CVE-2025-23047 in the wild and no public exploit code.

## Other vulnerabilities in cilium

- [CVE-2026-49445](https://insights.sbomify.com/CVE-2026-49445/): Cilium: Sensitive information disclosure and cluster disruption via local Envoy admin socket access (critical 9.2)
- [CVE-2022-29178](https://insights.sbomify.com/CVE-2022-29178/): Incorrect Default Permissions in Cilium (high 8.8)
- [CVE-2024-28860](https://insights.sbomify.com/CVE-2024-28860/): Insecure IPsec transport encryption in Cilium (high 8.0)
- [CVE-2026-41520](https://insights.sbomify.com/CVE-2026-41520/): Cillium exposes sensitive information included in the cilium-bugtool debug archive (high 7.9)
- [CVE-2024-37307](https://insights.sbomify.com/CVE-2024-37307/): Cilium leaks sensitive information in cilium-bugtool (high 7.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-23047 and fix it if it is affected.

What it is: CVE-2025-23047 is a medium-severity vulnerability in cilium, published on 22 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-23047 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/cilium/cilium (Go): affected from 1.14.0; fixed in 1.14.19, 1.15.13, 1.16.6
- github.com/cilium/cilium (Go): affected from 1.14.0; fixed in 1.14.19
- github.com/cilium/cilium (Go): affected from 1.14.0; fixed in 1.14.19
- github.com/cilium/cilium (Go): affected from 1.15.0; fixed in 1.15.13
- github.com/cilium/cilium (Go): affected from 1.15.0; fixed in 1.15.13
- github.com/cilium/cilium (Go): affected from 1.16.0; fixed in 1.16.6
- github.com/cilium/cilium (Go): affected from 1.16.0; fixed in 1.16.6
- cilium (Bitnami): affected from 1.14.0; fixed in 1.16.5
- cilium-operator (Bitnami): affected from 1.15.4; fixed in 1.16.5
- hubble-relay (Bitnami): affected from 1.14.0; fixed in 1.16.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-23047/ (Markdown: https://insights.sbomify.com/CVE-2025-23047/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-23047
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-23047
- OSV: https://osv.dev/vulnerability/CVE-2025-23047

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-23047/
Summaries are generated and may contain mistakes; the official description above is the record.
