{"answers":{"affected":"1 open source package ship an affected version, including apache. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-23048 exists.","fix":"Upgrade apache to 2.4.64 or later.","what":"CVE-2025-23048 is a critical authentication bypass vulnerability in Apache Http Server, published on 10 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-23048 and fix it if it is affected.\n\nWhat it is: CVE-2025-23048 is a critical authentication bypass vulnerability in Apache Http Server, published on 10 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-23048 exists.\n\nAffected packages and fixed versions:\n- apache (Bitnami): affected from 2.4.35; fixed in 2.4.64\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-23048/ (Markdown: https://insights.sbomify.com/CVE-2025-23048/index.md)","id":"CVE-2025-23048","markdown":"https://insights.sbomify.com/CVE-2025-23048/index.md","name":"CVE-2025-23048","record":{"aliases":["ALPINE-CVE-2025-23048","AZL-65163","AZL-65223","BELL-CVE-2025-23048","BIT-apache-2025-23048","CLSA-2025-1757428404","CLSA-2026-1773772035","DEBIAN-CVE-2025-23048","GHSA-gh64-76r6-qhpc","MINI-c6rx-qx33-qp7x","UBUNTU-CVE-2025-23048"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache HTTP Server","requires_auth":"none","summary":"Trusted clients can bypass access controls and access restricted virtual hosts via TLS session resumption in specific multi-vhost configurations.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"http_server","vendor":"apache"}],"cvss":{"score":9.1,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"}],"description":"In some mod_ssl configurations on Apache HTTP Server 2.4.35 through to 2.4.63, an access control bypass by trusted clients is possible using TLS 1.3 session resumption.\n\nConfigurations are affected when mod_ssl is configured for multiple virtual hosts, with each restricted to a different set of trusted client certificates (for example with a different SSLCACertificateFile/Path setting). In such a case, a client trusted to access one virtual host may be able to access another virtual host, if SSLStrictSNIVHostCheck is not enabled in either virtual host.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":"2025-10-22","github_poc":1,"max_poc_stars":4,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-10-22T01:36:10Z","kind":"github_poc","ref":"https://github.com/absholi7ly/CVE-2025-23048-POC","stars":4,"title":"Apache HTTP Server versions 2.4.35 – 2.4.63 are vulnerable to a client certificate authentication bypass when TLS 1.3 session resumption is used across virtual hosts with different `SSLCACertificateFile` directives."}],"tier":"weaponised"},"has_fix":true,"headline":"Apache HTTP Server: mod_ssl access control bypass with session resumption","id":"CVE-2025-23048","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:http_server","products":["apache:http_server"],"type":"auth_bypass","year":"2025"},"n_packages":1,"n_references":1,"next":{"headline":"Command injection in OrthoView","id":"CVE-2025-23049"},"packages":[{"ecosystem":"Bitnami","fixed":["2.4.64"],"introduced":["2.4.35"],"last_affected":[],"package":"apache","purl":"pkg:bitnami/apache","source":"BIT-apache-2025-23048"}],"prev":{"headline":"Cilium vulnerable to information leakage via insecure default Hubble UI CORS header","id":"CVE-2025-23047"},"products":["Apache HTTP Server"],"published":"2025-07-10","related":[{"cvss_score":9.8,"headline":"Apache HTTP Server Path Traversal","id":"CVE-2021-42013","kev_date_added":"2021-11-03","published":"2021-10-07"},{"cvss_score":9.1,"headline":"Apache HTTP Server Improper Escaping of Output","id":"CVE-2024-38475","kev_date_added":"2025-05-01","published":"2024-07-01"},{"cvss_score":9,"headline":"Apache HTTP Server-Side Request Forgery (SSRF)","id":"CVE-2021-40438","kev_date_added":"2021-12-01","published":"2021-09-16"},{"cvss_score":7.8,"headline":"Apache HTTP Server Privilege Escalation","id":"CVE-2019-0211","kev_date_added":"2021-11-03","published":"2019-04-08"},{"cvss_score":7.5,"headline":"Apache HTTP Server Path Traversal","id":"CVE-2021-41773","kev_date_added":"2021-11-03","published":"2021-10-05"},{"cvss_score":10,"headline":"Use after free in n/a","id":"CVE-2010-0425","kev_date_added":null,"published":"2010-03-05"},{"cvss_score":10,"headline":"Auth bypass in n/a","id":"CVE-2005-2700","kev_date_added":null,"published":"2005-09-06"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-02-26","vendors":["Apache Software Foundation"]},"summary":"Trusted clients can bypass access controls and access restricted virtual hosts via TLS session resumption in specific multi-vhost configurations.","url":"https://insights.sbomify.com/CVE-2025-23048/"}