# CVE-2025-23048: Apache HTTP Server: mod_ssl access control bypass with session resumption

> Trusted clients can bypass access controls and access restricted virtual hosts via TLS session resumption in specific multi-vhost configurations.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2025
- **Updated:** 26 Feb 2026
- **Also known as:** ALPINE-CVE-2025-23048, AZL-65163, AZL-65223, BELL-CVE-2025-23048, BIT-apache-2025-23048, CLSA-2025-1757428404, CLSA-2026-1773772035, DEBIAN-CVE-2025-23048, GHSA-gh64-76r6-qhpc, MINI-c6rx-qx33-qp7x, UBUNTU-CVE-2025-23048

## What is CVE-2025-23048?

CVE-2025-23048 is a critical authentication bypass vulnerability in Apache Http Server, published on 10 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In some mod_ssl configurations on Apache HTTP Server 2.4.35 through to 2.4.63, an access control bypass by trusted clients is possible using TLS 1.3 session resumption.

Configurations are affected when mod_ssl is configured for multiple virtual hosts, with each restricted to a different set of trusted client certificates (for example with a different SSLCACertificateFile/Path setting). In such a case, a client trusted to access one virtual host may be able to access another virtual host, if SSLStrictSNIVHostCheck is not enabled in either virtual host.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2025-23048?

1 open source package ship an affected version, including apache. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | From 2.4.35 | 2.4.64 |

Products: Apache Http Server.

## How do I fix CVE-2025-23048?

Upgrade apache to 2.4.64 or later.

## Is CVE-2025-23048 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-23048 exists.

Public exploit code:

- Apache HTTP Server versions 2.4.35 – 2.4.63 are vulnerable to a client certificate authentication bypass when TLS 1.3 session resumption is used across virtual hosts with different `SSLCACertificateFile` directives. (github_poc): https://github.com/absholi7ly/CVE-2025-23048-POC

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-23048 and fix it if it is affected.

What it is: CVE-2025-23048 is a critical authentication bypass vulnerability in Apache Http Server, published on 10 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-23048 exists.

Affected packages and fixed versions:
- apache (Bitnami): affected from 2.4.35; fixed in 2.4.64

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-23048/ (Markdown: https://insights.sbomify.com/CVE-2025-23048/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-23048
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-23048
- OSV: https://osv.dev/vulnerability/CVE-2025-23048

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-23048/
Summaries are generated and may contain mistakes; the official description above is the record.
