CVE-2025-23050 Memory corruption in Qt
An attacker can cause a denial of service in applications using Qt's Bluetooth controller by sending malformed ATT commands that trigger an out-of-bounds read or division by zero.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-23050?
CVE-2025-23050 is a low-severity memory corruption vulnerability in Qt, published on 31 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
QLowEnergyController in Qt before 6.8.2 mishandles malformed Bluetooth ATT commands, leading to an out-of-bounds read (or division by zero). This is fixed in 5.15.19, 6.5.9, and 6.8.2.
Weakness: CWE-125
Which versions are affected by CVE-2025-23050?
Linux distribution packages (6)
qt6-connectivity SUSE:Package Hub 15 SP6 | All versions | 6.6.3-bp156.2.3.1 |
qt6-connectivity-docs SUSE:Package Hub 15 SP6 | All versions | 6.6.3-bp156.2.3.1 |
qt6-connectivity openSUSE:Leap 15.6 | All versions | 6.6.3-bp156.2.3.1 |
qt6-connectivity-docs openSUSE:Leap 15.6 | All versions | 6.6.3-bp156.2.3.1 |
libqt5-qtconnectivity openSUSE:Tumbleweed | All versions | 5.15.16+kde2-1.1 |
qt6-connectivity openSUSE:Tumbleweed | All versions | 6.8.1-2.1 |
How do I fix CVE-2025-23050?
Upgrade to a fixed version.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2025-23050 being exploited?
There is no known exploitation of CVE-2025-23050 in the wild and no public exploit code.
Sources
Also known as AZL-69557, DEBIAN-CVE-2025-23050, GHSA-pj6p-fx56-wq5h, OESA-2025-1087, OESA-2025-1088, OESA-2025-1089 and 4 more.