{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-23050 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2025-23050 is a low-severity memory corruption vulnerability in Qt, published on 31 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-23050 and fix it if it is affected.\n\nWhat it is: CVE-2025-23050 is a low-severity memory corruption vulnerability in Qt, published on 31 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-23050 in the wild and no public exploit code.\n\nAffected product: Qt. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-23050/ (Markdown: https://insights.sbomify.com/CVE-2025-23050/index.md)","id":"CVE-2025-23050","markdown":"https://insights.sbomify.com/CVE-2025-23050/index.md","name":"CVE-2025-23050","record":{"aliases":["AZL-69557","DEBIAN-CVE-2025-23050","GHSA-pj6p-fx56-wq5h","OESA-2025-1087","OESA-2025-1088","OESA-2025-1089","UBUNTU-CVE-2025-23050","openSUSE-SU-2025:0033-1","openSUSE-SU-2025:14692-1","openSUSE-SU-2025:14716-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Qt Bluetooth library","requires_auth":"none","summary":"An attacker can cause a denial of service in applications using Qt's Bluetooth controller by sending malformed ATT commands that trigger an out-of-bounds read or division by zero.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":3.1,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"QLowEnergyController in Qt before 6.8.2 mishandles malformed Bluetooth ATT commands, leading to an out-of-bounds read (or division by zero). This is fixed in 5.15.19, 6.5.9, and 6.8.2.","ecosystems":["SUSE:Package Hub 15 SP6","openSUSE:Leap 15.6","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in Qt","id":"CVE-2025-23050","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2025"},"n_packages":6,"n_references":2,"next":{"headline":"Authenticated Remote Code Execution in AOS Web-based Management Interface","id":"CVE-2025-23051"},"packages":[{"ecosystem":"SUSE:Package Hub 15 SP6","fixed":["6.6.3-bp156.2.3.1"],"introduced":["0"],"last_affected":[],"package":"qt6-connectivity","purl":"pkg:rpm/suse/qt6-connectivity\u0026distro=SUSE%20Package%20Hub%2015%20SP6","source":"openSUSE-SU-2025:0033-1"},{"ecosystem":"SUSE:Package Hub 15 SP6","fixed":["6.6.3-bp156.2.3.1"],"introduced":["0"],"last_affected":[],"package":"qt6-connectivity-docs","purl":"pkg:rpm/suse/qt6-connectivity-docs\u0026distro=SUSE%20Package%20Hub%2015%20SP6","source":"openSUSE-SU-2025:0033-1"},{"ecosystem":"openSUSE:Leap 15.6","fixed":["6.6.3-bp156.2.3.1"],"introduced":["0"],"last_affected":[],"package":"qt6-connectivity","purl":"pkg:rpm/opensuse/qt6-connectivity\u0026distro=openSUSE%20Leap%2015.6","source":"openSUSE-SU-2025:0033-1"},{"ecosystem":"openSUSE:Leap 15.6","fixed":["6.6.3-bp156.2.3.1"],"introduced":["0"],"last_affected":[],"package":"qt6-connectivity-docs","purl":"pkg:rpm/opensuse/qt6-connectivity-docs\u0026distro=openSUSE%20Leap%2015.6","source":"openSUSE-SU-2025:0033-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["5.15.16+kde2-1.1"],"introduced":["0"],"last_affected":[],"package":"libqt5-qtconnectivity","purl":"pkg:rpm/opensuse/libqt5-qtconnectivity\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:14716-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["6.8.1-2.1"],"introduced":["0"],"last_affected":[],"package":"qt6-connectivity","purl":"pkg:rpm/opensuse/qt6-connectivity\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:14692-1"}],"prev":{"headline":"Command injection in OrthoView","id":"CVE-2025-23049"},"products":["Qt"],"published":"2025-10-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-31","vendors":["Qt"]},"summary":"An attacker can cause a denial of service in applications using Qt's Bluetooth controller by sending malformed ATT commands that trigger an out-of-bounds read or division by zero.","url":"https://insights.sbomify.com/CVE-2025-23050/"}