# CVE-2025-23050: Memory corruption in Qt

> An attacker can cause a denial of service in applications using Qt's Bluetooth controller by sending malformed ATT commands that trigger an out-of-bounds read or division by zero.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Oct 2025
- **Updated:** 31 Oct 2025
- **Also known as:** AZL-69557, DEBIAN-CVE-2025-23050, GHSA-pj6p-fx56-wq5h, OESA-2025-1087, OESA-2025-1088, OESA-2025-1089, UBUNTU-CVE-2025-23050, openSUSE-SU-2025:0033-1, openSUSE-SU-2025:14692-1, openSUSE-SU-2025:14716-1

## What is CVE-2025-23050?

CVE-2025-23050 is a low-severity memory corruption vulnerability in Qt, published on 31 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

QLowEnergyController in Qt before 6.8.2 mishandles malformed Bluetooth ATT commands, leading to an out-of-bounds read (or division by zero). This is fixed in 5.15.19, 6.5.9, and 6.8.2.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2025-23050?


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `qt6-connectivity` | SUSE:Package Hub 15 SP6 | All versions | 6.6.3-bp156.2.3.1 |
| `qt6-connectivity-docs` | SUSE:Package Hub 15 SP6 | All versions | 6.6.3-bp156.2.3.1 |
| `qt6-connectivity` | openSUSE:Leap 15.6 | All versions | 6.6.3-bp156.2.3.1 |
| `qt6-connectivity-docs` | openSUSE:Leap 15.6 | All versions | 6.6.3-bp156.2.3.1 |
| `libqt5-qtconnectivity` | openSUSE:Tumbleweed | All versions | 5.15.16+kde2-1.1 |
| `qt6-connectivity` | openSUSE:Tumbleweed | All versions | 6.8.1-2.1 |

## How do I fix CVE-2025-23050?

Upgrade to a fixed version.

## Is CVE-2025-23050 being exploited?

There is no known exploitation of CVE-2025-23050 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-23050 and fix it if it is affected.

What it is: CVE-2025-23050 is a low-severity memory corruption vulnerability in Qt, published on 31 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-23050 in the wild and no public exploit code.

Affected product: Qt. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-23050/ (Markdown: https://insights.sbomify.com/CVE-2025-23050/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-23050
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-23050
- OSV: https://osv.dev/vulnerability/CVE-2025-23050

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-23050/
Summaries are generated and may contain mistakes; the official description above is the record.
