CVE-2025-23081 Various security vulnerabilities in Extension:DataTransfer
Attackers can execute arbitrary scripts or perform unauthorized actions via CSRF and XSS vulnerabilities in the MediaWiki DataTransfer extension.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-23081?
CVE-2025-23081 is a medium-severity cross-site scripting vulnerability in Wikimedia Foundation Mediawiki - DataTransfer Extension, published on 14 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cross-Site Request Forgery (CSRF), Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation Mediawiki - DataTransfer Extension allows Cross Site Request Forgery, Cross-Site Scripting (XSS).This issue affects Mediawiki - DataTransfer Extension: from 1.39.X before 1.39.11, from 1.41.X before 1.41.3, from 1.42.X before 1.42.2.
Which versions are affected by CVE-2025-23081?
6 open source packages ship an affected version, including mediawiki/data-transfer.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki/data-transfer Packagist | From 1.39.0 | 1.39.11 |
mediawiki/data-transfer Packagist | From 1.39.0 | 1.39.11 |
mediawiki/data-transfer Packagist | From 1.41.0 | 1.41.3 |
mediawiki/data-transfer Packagist | From 1.41.0 | 1.41.3 |
mediawiki/data-transfer Packagist | From 1.42.0 | 1.42.2 |
mediawiki/data-transfer Packagist | From 1.42.0 | 1.42.2 |
How do I fix CVE-2025-23081?
Upgrade mediawiki/data-transfer to a fixed version for your release line: 1.39.11, 1.41.3 or 1.42.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-23081 being exploited?
There is no known exploitation of CVE-2025-23081 in the wild and no public exploit code.
Sources
Also known as GHSA-c3h5-h73c-29hq.