# CVE-2025-23081: Various security vulnerabilities in Extension:DataTransfer

> Attackers can execute arbitrary scripts or perform unauthorized actions via CSRF and XSS vulnerabilities in the MediaWiki DataTransfer extension.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Jan 2025
- **Updated:** 13 Mar 2025
- **Also known as:** GHSA-c3h5-h73c-29hq

## What is CVE-2025-23081?

CVE-2025-23081 is a medium-severity cross-site scripting vulnerability in Wikimedia Foundation Mediawiki - DataTransfer Extension, published on 14 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-Site Request Forgery (CSRF), Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation Mediawiki - DataTransfer Extension allows Cross Site Request Forgery, Cross-Site Scripting (XSS).This issue affects Mediawiki - DataTransfer Extension: from 1.39.X before 1.39.11, from 1.41.X before 1.41.3, from 1.42.X before 1.42.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2025-23081?

6 open source packages ship an affected version, including mediawiki/data-transfer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki/data-transfer` | Packagist | From 1.39.0 | 1.39.11 |
| `mediawiki/data-transfer` | Packagist | From 1.39.0 | 1.39.11 |
| `mediawiki/data-transfer` | Packagist | From 1.41.0 | 1.41.3 |
| `mediawiki/data-transfer` | Packagist | From 1.41.0 | 1.41.3 |
| `mediawiki/data-transfer` | Packagist | From 1.42.0 | 1.42.2 |
| `mediawiki/data-transfer` | Packagist | From 1.42.0 | 1.42.2 |

## How do I fix CVE-2025-23081?

Upgrade mediawiki/data-transfer to a fixed version for your release line: 1.39.11, 1.41.3 or 1.42.2.

## Is CVE-2025-23081 being exploited?

There is no known exploitation of CVE-2025-23081 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-23081 and fix it if it is affected.

What it is: CVE-2025-23081 is a medium-severity cross-site scripting vulnerability in Wikimedia Foundation Mediawiki - DataTransfer Extension, published on 14 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-23081 in the wild and no public exploit code.

Affected packages and fixed versions:
- mediawiki/data-transfer (Packagist): affected from 1.39.0; fixed in 1.39.11
- mediawiki/data-transfer (Packagist): affected from 1.39.0; fixed in 1.39.11
- mediawiki/data-transfer (Packagist): affected from 1.41.0; fixed in 1.41.3
- mediawiki/data-transfer (Packagist): affected from 1.41.0; fixed in 1.41.3
- mediawiki/data-transfer (Packagist): affected from 1.42.0; fixed in 1.42.2
- mediawiki/data-transfer (Packagist): affected from 1.42.0; fixed in 1.42.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-23081/ (Markdown: https://insights.sbomify.com/CVE-2025-23081/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-23081
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-23081
- OSV: https://osv.dev/vulnerability/CVE-2025-23081

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-23081/
Summaries are generated and may contain mistakes; the official description above is the record.
