# CVE-2025-2314: Cross-site scripting in User Profile Builder – Beautiful User Registration Forms, User Profiles & User Role Editor

> Authenticated attackers with contributor access can inject arbitrary scripts via shortcodes, leading to stored XSS execution on victim pages.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Apr 2025
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-hx97-c52w-j6xr

## What is CVE-2025-2314?

CVE-2025-2314 is a medium-severity cross-site scripting vulnerability in cozmoslabs User Profile Builder – Beautiful User Registration Forms, User Profiles & User Role Editor, published on 16 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The User Profile Builder – Beautiful User Registration Forms, User Profiles & User Role Editor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's shortcodes in all versions up to, and including, 3.13.5 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
The issue was partially patched in version 3.13.6 of the plugin, and fully patched in 3.13.7.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-2314?


## How do I fix CVE-2025-2314?

No fix has been published for CVE-2025-2314 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-2314 being exploited?

There is no known exploitation of CVE-2025-2314 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-2314 and fix it if it is affected.

What it is: CVE-2025-2314 is a medium-severity cross-site scripting vulnerability in cozmoslabs User Profile Builder – Beautiful User Registration Forms, User Profiles & User Role Editor, published on 16 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-2314 in the wild and no public exploit code.

Affected product: cozmoslabs User Profile Builder – Beautiful User Registration Forms, User Profiles & User Role Editor. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-2314/ (Markdown: https://insights.sbomify.com/CVE-2025-2314/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-2314
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-2314
- OSV: https://osv.dev/vulnerability/CVE-2025-2314

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-2314/
Summaries are generated and may contain mistakes; the official description above is the record.
