{"answers":{"affected":"2 open source packages ship an affected version, including node and node-min.","exploited":"There is no known exploitation of CVE-2025-23167 in the wild and no public exploit code.","fix":"Upgrade node to 20.19.2 or later.","what":"CVE-2025-23167 is a medium-severity vulnerability in nodejs node, published on 19 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-23167 and fix it if it is affected.\n\nWhat it is: CVE-2025-23167 is a medium-severity vulnerability in nodejs node, published on 19 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-23167 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- node (Bitnami): affected all versions; fixed in 20.19.2\n- node-min (Bitnami): affected all versions; fixed in 20.19.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-23167/ (Markdown: https://insights.sbomify.com/CVE-2025-23167/index.md)","id":"CVE-2025-23167","markdown":"https://insights.sbomify.com/CVE-2025-23167/index.md","name":"CVE-2025-23167","record":{"aliases":["AZL-61914","AZL-65063","BELL-CVE-2025-23167","BIT-node-2025-23167","BIT-node-min-2025-23167","DEBIAN-CVE-2025-23167","ECHO-5136-5b45-28cc","GHSA-hchw-qwx7-4w4c","MINI-4hw5-4h77-c564","MINI-jc28-5j76-97h6"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js HTTP parser","requires_auth":"none","summary":"Attackers can bypass proxy access controls via HTTP request smuggling in Node.js 20 due to improper header termination.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-444","name":"Inconsistent Interpretation of HTTP Requests"}],"description":"A flaw in Node.js 20's HTTP parser allows improper termination of HTTP/1 headers using `\\r\\n\\rX` instead of the required `\\r\\n\\r\\n`.\nThis inconsistency enables request smuggling, allowing attackers to bypass proxy-based access controls and submit unauthorized requests.\n\nThe issue was resolved by upgrading `llhttp` to version 9, which enforces correct header termination.\n\nImpact:\n* This vulnerability affects only Node.js 20.x users prior to the `llhttp` v9 upgrade.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":"2025-07-15","github_poc":1,"max_poc_stars":1,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-07-15T17:51:09Z","kind":"github_poc","ref":"https://github.com/abhisek3122/CVE-2025-23167","stars":1,"title":"Working exploit for CVE-2025-23167 – HTTP request smuggling in vulnerable Node.js 20.x versions before 20.19.2"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Other in node","id":"CVE-2025-23167","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"other","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"Security feature bypass in Director","id":"CVE-2025-23168"},"packages":[{"ecosystem":"Bitnami","fixed":["20.19.2"],"introduced":["0"],"last_affected":[],"package":"node","purl":"pkg:bitnami/node","source":"BIT-node-2025-23167"},{"ecosystem":"Bitnami","fixed":["20.19.2"],"introduced":["0"],"last_affected":[],"package":"node-min","purl":"pkg:bitnami/node-min","source":"BIT-node-min-2025-23167"}],"prev":{"headline":"Denial of service in node","id":"CVE-2025-23166"},"products":["node"],"published":"2025-05-19","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-27","vendors":["nodejs"]},"summary":"Attackers can bypass proxy access controls via HTTP request smuggling in Node.js 20 due to improper header termination.","url":"https://insights.sbomify.com/CVE-2025-23167/"}