# CVE-2025-23167: Other in node

> Attackers can bypass proxy access controls via HTTP request smuggling in Node.js 20 due to improper header termination.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 May 2025
- **Updated:** 27 May 2025
- **Also known as:** AZL-61914, AZL-65063, BELL-CVE-2025-23167, BIT-node-2025-23167, BIT-node-min-2025-23167, DEBIAN-CVE-2025-23167, ECHO-5136-5b45-28cc, GHSA-hchw-qwx7-4w4c, MINI-4hw5-4h77-c564, MINI-jc28-5j76-97h6

## What is CVE-2025-23167?

CVE-2025-23167 is a medium-severity vulnerability in nodejs node, published on 19 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw in Node.js 20's HTTP parser allows improper termination of HTTP/1 headers using `\r\n\rX` instead of the required `\r\n\r\n`.
This inconsistency enables request smuggling, allowing attackers to bypass proxy-based access controls and submit unauthorized requests.

The issue was resolved by upgrading `llhttp` to version 9, which enforces correct header termination.

Impact:
* This vulnerability affects only Node.js 20.x users prior to the `llhttp` v9 upgrade.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2025-23167?

2 open source packages ship an affected version, including node and node-min.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node` | Bitnami | All versions | 20.19.2 |
| `node-min` | Bitnami | All versions | 20.19.2 |

## How do I fix CVE-2025-23167?

Upgrade node to 20.19.2 or later.

## Is CVE-2025-23167 being exploited?

There is no known exploitation of CVE-2025-23167 in the wild and no public exploit code.

Public exploit code:

- Working exploit for CVE-2025-23167 – HTTP request smuggling in vulnerable Node.js 20.x versions before 20.19.2 (github_poc): https://github.com/abhisek3122/CVE-2025-23167

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-23167 and fix it if it is affected.

What it is: CVE-2025-23167 is a medium-severity vulnerability in nodejs node, published on 19 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-23167 in the wild and no public exploit code.

Affected packages and fixed versions:
- node (Bitnami): affected all versions; fixed in 20.19.2
- node-min (Bitnami): affected all versions; fixed in 20.19.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-23167/ (Markdown: https://insights.sbomify.com/CVE-2025-23167/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-23167
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-23167
- OSV: https://osv.dev/vulnerability/CVE-2025-23167

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-23167/
Summaries are generated and may contain mistakes; the official description above is the record.
