CVE-2025-23197 matrix-hookshot has a Potential Denial of Service when Hookshot is configured with GitHub support
Attackers can cause a crash on restart in Matrix Hookshot when GitHub support is enabled, requiring an upgrade to fix.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2025-23197?
CVE-2025-23197 is a medium-severity denial of service vulnerability in matrix-org matrix-hookshot, published on 27 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
matrix-hookshot is a Matrix bot for connecting to external services like GitHub, GitLab, JIRA, and more. When Hookshot 6 version 6.0.1 or below, or Hookshot 5 version 5.4.1 or below, is configured with GitHub support, it is vulnerable to a Denial of Service (DoS) whereby it can crash on restart due to a missing check. The impact is greater to you untrusted users can add their own GitHub organizations to Hookshot in order to connect their room to a repository. This vulnerability is fixed in 6.0.2 and 5.4.2.
Weakness: CWE-754
Which versions are affected by CVE-2025-23197?
How do I fix CVE-2025-23197?
No fix has been published for CVE-2025-23197 yet. Limit exposure of the affected software until one is available.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-23197 being exploited?
There is no known exploitation of CVE-2025-23197 in the wild and no public exploit code.
Sources
Also known as GHSA-cr4q-jf47-3645.