# CVE-2025-23197: matrix-hookshot has a Potential Denial of Service when Hookshot is configured with GitHub support

> Attackers can cause a crash on restart in Matrix Hookshot when GitHub support is enabled, requiring an upgrade to fix.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 Jan 2025
- **Updated:** 12 Feb 2025
- **Also known as:** GHSA-cr4q-jf47-3645

## What is CVE-2025-23197?

CVE-2025-23197 is a medium-severity denial of service vulnerability in matrix-org matrix-hookshot, published on 27 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

matrix-hookshot is a Matrix bot for connecting to external services like GitHub, GitLab, JIRA, and more. When Hookshot 6 version 6.0.1 or below, or Hookshot 5 version 5.4.1 or below, is configured with GitHub support, it is vulnerable to a Denial of Service (DoS) whereby it can crash on restart due to a missing check. The impact is greater to you untrusted users can add their own GitHub organizations to Hookshot in order to connect their room to a repository. This vulnerability is fixed in 6.0.2 and 5.4.2.

Weakness: CWE-754 (Improper Check for Unusual or Exceptional Conditions)

## Which versions are affected by CVE-2025-23197?


## How do I fix CVE-2025-23197?

No fix has been published for CVE-2025-23197 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-23197 being exploited?

There is no known exploitation of CVE-2025-23197 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-23197 and fix it if it is affected.

What it is: CVE-2025-23197 is a medium-severity denial of service vulnerability in matrix-org matrix-hookshot, published on 27 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-23197 in the wild and no public exploit code.

Affected product: matrix-org matrix-hookshot. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-23197/ (Markdown: https://insights.sbomify.com/CVE-2025-23197/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-23197
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-23197
- OSV: https://osv.dev/vulnerability/CVE-2025-23197

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-23197/
Summaries are generated and may contain mistakes; the official description above is the record.
