{"answers":{"affected":"2 open source packages ship an affected version, including api-platform/core.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-23204 exists.","fix":"Upgrade api-platform/core to 3.3.15 or later.","what":"CVE-2025-23204 is a medium-severity missing authorization vulnerability in api-platform core, published on 24 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-23204 and fix it if it is affected.\n\nWhat it is: CVE-2025-23204 is a medium-severity missing authorization vulnerability in api-platform core, published on 24 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-23204 exists.\n\nAffected packages and fixed versions:\n- api-platform/core (Packagist): affected from 3.3.8; fixed in 3.3.15\n- api-platform/core (Packagist): affected from 3.3.8; fixed in 3.3.15\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-23204/ (Markdown: https://insights.sbomify.com/CVE-2025-23204/index.md)","id":"CVE-2025-23204","markdown":"https://insights.sbomify.com/CVE-2025-23204/index.md","name":"CVE-2025-23204","record":{"aliases":["GHSA-7mxx-3cgm-xxv3"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"API Platform Core","requires_auth":"high_privilege","summary":"Attackers can bypass GraphQL security checks when only post-resolver security is configured, potentially accessing unauthorized data.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":4.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"API Platform Core is a system to create hypermedia-driven REST and GraphQL APIs. Starting in version 3.3.8, a security check that gets called after GraphQl resolvers is always replaced by another one as there's no break in a clause. As this falls back to `security`, the impact is there only when there's only a security after resolver and none inside security. Version 3.3.15 contains a patch for the issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"GraphQl securityAfterResolver not called","id":"CVE-2025-23204","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"missing_authorization","year":"2025"},"n_packages":2,"n_references":5,"next":{"headline":"`frame-ancestors: self` grants all users access to formgrader in nbgrader","id":"CVE-2025-23205"},"packages":[{"ecosystem":"Packagist","fixed":["3.3.15"],"introduced":["3.3.8"],"last_affected":[],"package":"api-platform/core","purl":null,"source":"GHSA-7mxx-3cgm-xxv3"},{"ecosystem":"Packagist","fixed":["3.3.15"],"introduced":["3.3.8"],"last_affected":[],"package":"api-platform/core","purl":"pkg:composer/api-platform/core","source":"GHSA-7mxx-3cgm-xxv3"}],"prev":{"headline":"Icinga has rest API endpoints accessible to restricted users","id":"CVE-2025-23203"},"products":["core"],"published":"2025-03-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-24","vendors":["api-platform"]},"summary":"Attackers can bypass GraphQL security checks when only post-resolver security is configured, potentially accessing unauthorized data.","url":"https://insights.sbomify.com/CVE-2025-23204/"}