# CVE-2025-23204: GraphQl securityAfterResolver not called

> Attackers can bypass GraphQL security checks when only post-resolver security is configured, potentially accessing unauthorized data.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Mar 2025
- **Updated:** 24 Mar 2025
- **Also known as:** GHSA-7mxx-3cgm-xxv3

## What is CVE-2025-23204?

CVE-2025-23204 is a medium-severity missing authorization vulnerability in api-platform core, published on 24 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

API Platform Core is a system to create hypermedia-driven REST and GraphQL APIs. Starting in version 3.3.8, a security check that gets called after GraphQl resolvers is always replaced by another one as there's no break in a clause. As this falls back to `security`, the impact is there only when there's only a security after resolver and none inside security. Version 3.3.15 contains a patch for the issue.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-23204?

2 open source packages ship an affected version, including api-platform/core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `api-platform/core` | Packagist | From 3.3.8 | 3.3.15 |
| `api-platform/core` | Packagist | From 3.3.8 | 3.3.15 |

## How do I fix CVE-2025-23204?

Upgrade api-platform/core to 3.3.15 or later.

## Is CVE-2025-23204 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-23204 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-23204 and fix it if it is affected.

What it is: CVE-2025-23204 is a medium-severity missing authorization vulnerability in api-platform core, published on 24 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-23204 exists.

Affected packages and fixed versions:
- api-platform/core (Packagist): affected from 3.3.8; fixed in 3.3.15
- api-platform/core (Packagist): affected from 3.3.8; fixed in 3.3.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-23204/ (Markdown: https://insights.sbomify.com/CVE-2025-23204/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-23204
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-23204
- OSV: https://osv.dev/vulnerability/CVE-2025-23204

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-23204/
Summaries are generated and may contain mistakes; the official description above is the record.
