{"answers":{"affected":"2 open source packages ship an affected version, including katex. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-23207 in the wild and no public exploit code.","fix":"Upgrade katex to 0.16.21 or later.","what":"CVE-2025-23207 is a medium-severity cross-site scripting vulnerability in KaTeX, published on 17 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-23207 and fix it if it is affected.\n\nWhat it is: CVE-2025-23207 is a medium-severity cross-site scripting vulnerability in KaTeX, published on 17 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-23207 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- katex (npm): affected from 0.12.0; fixed in 0.16.21\n- katex (npm): affected from 0.12.0; fixed in 0.16.21\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-23207/ (Markdown: https://insights.sbomify.com/CVE-2025-23207/index.md)","id":"CVE-2025-23207","markdown":"https://insights.sbomify.com/CVE-2025-23207/index.md","name":"CVE-2025-23207","record":{"aliases":["DEBIAN-CVE-2025-23207","GHSA-cg87-wmx4-v546","UBUNTU-CVE-2025-23207"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"JavaScript math rendering library","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary JavaScript via malicious TeX input in KaTeX when the trust option is enabled, requiring an upgrade or configuration change.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"katex","vendor":"katex"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-116","name":"Improper Encoding or Escaping of Output"}],"description":"KaTeX is a fast, easy-to-use JavaScript library for TeX math rendering on the web. KaTeX users who render untrusted mathematical expressions with `renderToString` could encounter malicious input using `\\htmlData` that runs arbitrary JavaScript, or generate invalid HTML. Users are advised to upgrade to KaTeX v0.16.21 to remove this vulnerability. Users unable to upgrade should avoid use of or turn off the `trust` option, or set it to forbid `\\htmlData` commands, forbid inputs containing the substring `\"\\\\htmlData\"` and sanitize HTML output from KaTeX.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"\\htmlData does not validate attribute names in KaTeX","id":"CVE-2025-23207","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"IdP group membership revocation ignored in zot","id":"CVE-2025-23208"},"packages":[{"ecosystem":"npm","fixed":["0.16.21"],"introduced":["0.12.0"],"last_affected":[],"package":"katex","purl":null,"source":"GHSA-cg87-wmx4-v546"},{"ecosystem":"npm","fixed":["0.16.21"],"introduced":["0.12.0"],"last_affected":[],"package":"katex","purl":"pkg:npm/katex","source":"GHSA-cg87-wmx4-v546"}],"prev":{"headline":"IAM OIDC custom resource allows connection to unauthorized OIDC provider in aws-cdk","id":"CVE-2025-23206"},"products":["KaTeX"],"published":"2025-01-17","related":[{"cvss_score":6.5,"headline":"KaTeX's maxExpand bypassed by \\edef","id":"CVE-2024-28243","kev_date_added":null,"published":"2024-03-25"},{"cvss_score":6.5,"headline":"KaTeX's maxExpand bypassed by Unicode sub/superscripts","id":"CVE-2024-28244","kev_date_added":null,"published":"2024-03-25"},{"cvss_score":6.3,"headline":"KaTeX's \\includegraphics does not escape filename","id":"CVE-2024-28245","kev_date_added":null,"published":"2024-03-25"},{"cvss_score":5.5,"headline":"KaTeX is missing normalization of the protocol in URLs allows bypassing forbidden protocols","id":"CVE-2024-28246","kev_date_added":null,"published":"2024-03-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-17","vendors":["KaTeX"]},"summary":"Attackers can execute arbitrary JavaScript via malicious TeX input in KaTeX when the trust option is enabled, requiring an upgrade or configuration change.","url":"https://insights.sbomify.com/CVE-2025-23207/"}