# CVE-2025-23207: \htmlData does not validate attribute names in KaTeX

> Attackers can execute arbitrary JavaScript via malicious TeX input in KaTeX when the trust option is enabled, requiring an upgrade or configuration change.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jan 2025
- **Updated:** 17 Jan 2025
- **Also known as:** DEBIAN-CVE-2025-23207, GHSA-cg87-wmx4-v546, UBUNTU-CVE-2025-23207

## What is CVE-2025-23207?

CVE-2025-23207 is a medium-severity cross-site scripting vulnerability in KaTeX, published on 17 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

KaTeX is a fast, easy-to-use JavaScript library for TeX math rendering on the web. KaTeX users who render untrusted mathematical expressions with `renderToString` could encounter malicious input using `\htmlData` that runs arbitrary JavaScript, or generate invalid HTML. Users are advised to upgrade to KaTeX v0.16.21 to remove this vulnerability. Users unable to upgrade should avoid use of or turn off the `trust` option, or set it to forbid `\htmlData` commands, forbid inputs containing the substring `"\\htmlData"` and sanitize HTML output from KaTeX.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2025-23207?

2 open source packages ship an affected version, including katex. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `katex` | npm | From 0.12.0 | 0.16.21 |
| `katex` | npm | From 0.12.0 | 0.16.21 |

Products: Katex Katex.

## How do I fix CVE-2025-23207?

Upgrade katex to 0.16.21 or later.

## Is CVE-2025-23207 being exploited?

There is no known exploitation of CVE-2025-23207 in the wild and no public exploit code.

## Other vulnerabilities in KaTeX

- [CVE-2024-28243](https://insights.sbomify.com/CVE-2024-28243/): KaTeX's maxExpand bypassed by \edef (medium 6.5)
- [CVE-2024-28244](https://insights.sbomify.com/CVE-2024-28244/): KaTeX's maxExpand bypassed by Unicode sub/superscripts (medium 6.5)
- [CVE-2024-28245](https://insights.sbomify.com/CVE-2024-28245/): KaTeX's \includegraphics does not escape filename (medium 6.3)
- [CVE-2024-28246](https://insights.sbomify.com/CVE-2024-28246/): KaTeX is missing normalization of the protocol in URLs allows bypassing forbidden protocols (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-23207 and fix it if it is affected.

What it is: CVE-2025-23207 is a medium-severity cross-site scripting vulnerability in KaTeX, published on 17 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-23207 in the wild and no public exploit code.

Affected packages and fixed versions:
- katex (npm): affected from 0.12.0; fixed in 0.16.21
- katex (npm): affected from 0.12.0; fixed in 0.16.21

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-23207/ (Markdown: https://insights.sbomify.com/CVE-2025-23207/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-23207
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-23207
- OSV: https://osv.dev/vulnerability/CVE-2025-23207

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-23207/
Summaries are generated and may contain mistakes; the official description above is the record.
