{"answers":{"affected":"10 open source packages ship an affected version, including phpoffice/phpspreadsheet and phpoffice/phpexcel.","exploited":"There is no known exploitation of CVE-2025-23210 in the wild and no public exploit code.","fix":"Upgrade phpoffice/phpspreadsheet to a fixed version for your release line: 1.29.9, 2.1.8, 2.3.7 or 3.9.0.","what":"CVE-2025-23210 is a medium-severity cross-site scripting vulnerability in PHPOffice PhpSpreadsheet, published on 3 Feb 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-23210 and fix it if it is affected.\n\nWhat it is: CVE-2025-23210 is a medium-severity cross-site scripting vulnerability in PHPOffice PhpSpreadsheet, published on 3 Feb 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-23210 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.29.9\n- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.29.9\n- phpoffice/phpspreadsheet (Packagist): affected from 2.0.0; fixed in 2.1.8\n- phpoffice/phpspreadsheet (Packagist): affected from 2.0.0; fixed in 2.1.8\n- phpoffice/phpspreadsheet (Packagist): affected from 2.2.0; fixed in 2.3.7\n- phpoffice/phpspreadsheet (Packagist): affected from 2.2.0; fixed in 2.3.7\n- phpoffice/phpspreadsheet (Packagist): affected from 3.0.0; fixed in 3.9.0\n- phpoffice/phpspreadsheet (Packagist): affected from 3.0.0; fixed in 3.9.0\n- phpoffice/phpexcel (Packagist): affected all versions up to 1.8.2; no fix listed\n- phpoffice/phpexcel (Packagist): affected all versions up to 1.8.2; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-23210/ (Markdown: https://insights.sbomify.com/CVE-2025-23210/index.md)","id":"CVE-2025-23210","markdown":"https://insights.sbomify.com/CVE-2025-23210/index.md","name":"CVE-2025-23210","record":{"aliases":["GHSA-r57h-547h-w24f"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP spreadsheet library","requires_auth":"low_privilege","summary":"Attackers can bypass XSS sanitization in PhpSpreadsheet using the javascript protocol and special characters, potentially executing malicious scripts.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"phpoffice/phpspreadsheet is a pure PHP library for reading and writing spreadsheet files. Affected versions have been found to have a Bypass of the Cross-site Scripting (XSS) sanitizer using the javascript protocol and special characters. This issue has been addressed in versions 3.9.0, 2.3.7, 2.1.8, and 1.29.9. Users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Bypass XSS sanitizer using the javascript protocol and special characters in phpoffice/phpspreadsheet","id":"CVE-2025-23210","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":10,"n_references":2,"next":{"headline":"Tandoor Recipes - SSTI - Remote Code Execution","id":"CVE-2025-23211"},"packages":[{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["1.8.2"],"package":"phpoffice/phpexcel","purl":null,"source":"GHSA-r57h-547h-w24f"},{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["1.8.2"],"package":"phpoffice/phpexcel","purl":"pkg:composer/phpoffice/phpexcel","source":"GHSA-r57h-547h-w24f"},{"ecosystem":"Packagist","fixed":["1.29.9"],"introduced":["0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":null,"source":"GHSA-r57h-547h-w24f"},{"ecosystem":"Packagist","fixed":["1.29.9"],"introduced":["0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":"pkg:composer/phpoffice/phpspreadsheet","source":"GHSA-r57h-547h-w24f"},{"ecosystem":"Packagist","fixed":["2.1.8"],"introduced":["2.0.0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":null,"source":"GHSA-r57h-547h-w24f"},{"ecosystem":"Packagist","fixed":["2.1.8"],"introduced":["2.0.0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":"pkg:composer/phpoffice/phpspreadsheet","source":"GHSA-r57h-547h-w24f"},{"ecosystem":"Packagist","fixed":["2.3.7"],"introduced":["2.2.0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":null,"source":"GHSA-r57h-547h-w24f"},{"ecosystem":"Packagist","fixed":["2.3.7"],"introduced":["2.2.0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":"pkg:composer/phpoffice/phpspreadsheet","source":"GHSA-r57h-547h-w24f"},{"ecosystem":"Packagist","fixed":["3.9.0"],"introduced":["3.0.0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":null,"source":"GHSA-r57h-547h-w24f"},{"ecosystem":"Packagist","fixed":["3.9.0"],"introduced":["3.0.0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":"pkg:composer/phpoffice/phpspreadsheet","source":"GHSA-r57h-547h-w24f"}],"prev":{"headline":"Craft CMS Code Injection","id":"CVE-2025-23209"},"products":["PhpSpreadsheet"],"published":"2025-02-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-04","vendors":["PHPOffice"]},"summary":"Attackers can bypass XSS sanitization in PhpSpreadsheet using the javascript protocol and special characters, potentially executing malicious scripts.","url":"https://insights.sbomify.com/CVE-2025-23210/"}