# CVE-2025-23215: PMD Designer's release key passphrase (GPG) available on Maven Central in cleartext

> Attackers can potentially compromise release signing keys due to exposed passphrases, undermining software supply chain integrity for PMD users.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/U:Clear`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Jan 2025
- **Updated:** 4 Apr 2025
- **Also known as:** GHSA-88m4-h43f-wx84

## What is CVE-2025-23215?

CVE-2025-23215 is a critical vulnerability in pmd, published on 31 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PMD is an extensible multilanguage static code analyzer. The passphrase for the PMD and PMD Designer release signing keys are included in jar published to Maven Central. The private key itself is not known to have been compromised itself, but given its passphrase is, it must also be considered potentially compromised. As a mitigation, both compromised keys have been revoked so that no future use of the keys are possible. Note, that the published artifacts in Maven Central under the group id net.sourceforge.pmd are not compromised and the signatures are valid.

Weakness: CWE-540 (Inclusion of Sensitive Information in Source Code), CWE-312 (Cleartext Storage of Sensitive Information), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-23215?

6 open source packages ship an affected version, including net.sourceforge.pmd:pmd-core, net.sourceforge.pmd:pmd-designer and net.sourceforge.pmd:pmd-ui.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `net.sourceforge.pmd:pmd-core` | Maven | From 6.21.0 | 7.10.0 |
| `net.sourceforge.pmd:pmd-core` | Maven | From 6.21.0 | 7.10.0 |
| `net.sourceforge.pmd:pmd-designer` | Maven | From 7.0.0 | 7.10.0 |
| `net.sourceforge.pmd:pmd-designer` | Maven | From 7.0.0 | 7.10.0 |
| `net.sourceforge.pmd:pmd-ui` | Maven | From 6.14.0 to 6.19.0 | None |
| `net.sourceforge.pmd:pmd-ui` | Maven | From 6.14.0 to 6.19.0 | None |

## How do I fix CVE-2025-23215?

Upgrade net.sourceforge.pmd:pmd-core to 7.10.0 or later.

## Is CVE-2025-23215 being exploited?

There is no known exploitation of CVE-2025-23215 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-23215 and fix it if it is affected.

What it is: CVE-2025-23215 is a critical vulnerability in pmd, published on 31 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-23215 in the wild and no public exploit code.

Affected packages and fixed versions:
- net.sourceforge.pmd:pmd-core (Maven): affected from 6.21.0; fixed in 7.10.0
- net.sourceforge.pmd:pmd-core (Maven): affected from 6.21.0; fixed in 7.10.0
- net.sourceforge.pmd:pmd-designer (Maven): affected from 7.0.0; fixed in 7.10.0
- net.sourceforge.pmd:pmd-designer (Maven): affected from 7.0.0; fixed in 7.10.0
- net.sourceforge.pmd:pmd-ui (Maven): affected from 6.14.0 up to 6.19.0; no fix listed
- net.sourceforge.pmd:pmd-ui (Maven): affected from 6.14.0 up to 6.19.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-23215/ (Markdown: https://insights.sbomify.com/CVE-2025-23215/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-23215
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-23215
- OSV: https://osv.dev/vulnerability/CVE-2025-23215

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-23215/
Summaries are generated and may contain mistakes; the official description above is the record.
