CVE-2025-23217 Mitmweb API Authentication Bypass Using Proxy Server

High 8.2 Published Updated

Attackers can bypass authentication via the proxy server to access internal APIs, potentially leading to remote code execution in mitmweb.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-23217?

CVE-2025-23217 is a high-severity authentication bypass vulnerability in mitmproxy, published on 6 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

mitmproxy is a interactive TLS-capable intercepting HTTP proxy for penetration testers and software developers and mitmweb is a web-based interface for mitmproxy. In mitmweb 11.1.1 and below, a malicious client can use mitmweb's proxy server (bound to `*:8080` by default) to access mitmweb's internal API (bound to `127.0.0.1:8081` by default). In other words, while the cannot access the API directly, they can access the API through the proxy. An attacker may be able to escalate this SSRF-style access to remote code execution. The mitmproxy and mitmdump tools are unaffected. Only mitmweb is affected. This vulnerability has been fixed in mitmproxy 11.1.2 and above. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-441, CWE-288

Which versions are affected by CVE-2025-23217?

3 open source packages ship an affected version, including mitmproxy.

PackageAffectedFixed in
mitmproxy PyPIAll versions11.1.2
mitmproxy PyPIAll versions11.1.2
mitmproxy PyPIAll versions11.1.2

How do I fix CVE-2025-23217?

Upgrade mitmproxy to 11.1.2 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2025-23217 being exploited?

There is no known exploitation of CVE-2025-23217 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2025-23217, GHSA-wg33-5h85-7q5p, PYSEC-2026-1630, UBUNTU-CVE-2025-23217.

Is CVE-2025-23217 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free