{"answers":{"affected":"3 open source packages ship an affected version, including mitmproxy.","exploited":"There is no known exploitation of CVE-2025-23217 in the wild and no public exploit code.","fix":"Upgrade mitmproxy to 11.1.2 or later.","what":"CVE-2025-23217 is a high-severity authentication bypass vulnerability in mitmproxy, published on 6 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-23217 and fix it if it is affected.\n\nWhat it is: CVE-2025-23217 is a high-severity authentication bypass vulnerability in mitmproxy, published on 6 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-23217 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mitmproxy (PyPI): affected all versions; fixed in 11.1.2\n- mitmproxy (PyPI): affected all versions; fixed in 11.1.2\n- mitmproxy (PyPI): affected all versions; fixed in 11.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-23217/ (Markdown: https://insights.sbomify.com/CVE-2025-23217/index.md)","id":"CVE-2025-23217","markdown":"https://insights.sbomify.com/CVE-2025-23217/index.md","name":"CVE-2025-23217","record":{"aliases":["DEBIAN-CVE-2025-23217","GHSA-wg33-5h85-7q5p","PYSEC-2026-1630","UBUNTU-CVE-2025-23217"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"mitmweb proxy interface","requires_auth":"none","summary":"Attackers can bypass authentication via the proxy server to access internal APIs, potentially leading to remote code execution in mitmweb.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-441","name":"Unintended Proxy or Intermediary"},{"id":"CWE-288","name":"Authentication Bypass Using an Alternate Path or Channel"}],"description":"mitmproxy is a interactive TLS-capable intercepting HTTP proxy for penetration testers and software developers and mitmweb is a web-based interface for mitmproxy. In mitmweb 11.1.1 and below, a malicious client can use mitmweb's proxy server (bound to `*:8080` by default) to access mitmweb's internal API (bound to `127.0.0.1:8081` by default). In other words, while the cannot access the API directly, they can access the API through the proxy. An attacker may be able to escalate this SSRF-style access to remote code execution. The mitmproxy and mitmdump tools are unaffected. Only mitmweb is affected. This vulnerability has been fixed in mitmproxy 11.1.2 and above. Users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Mitmweb API Authentication Bypass Using Proxy Server","id":"CVE-2025-23217","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":3,"n_references":3,"next":{"headline":"WeGIA has a SQL Injection endpoint 'adicionar_especie.php' parameter 'especie'","id":"CVE-2025-23218"},"packages":[{"ecosystem":"PyPI","fixed":["11.1.2"],"introduced":["0"],"last_affected":[],"package":"mitmproxy","purl":null,"source":"GHSA-wg33-5h85-7q5p"},{"ecosystem":"PyPI","fixed":["11.1.2"],"introduced":["0"],"last_affected":[],"package":"mitmproxy","purl":"pkg:pypi/mitmproxy","source":"GHSA-wg33-5h85-7q5p"},{"ecosystem":"PyPI","fixed":["11.1.2"],"introduced":["0"],"last_affected":[],"package":"mitmproxy","purl":"pkg:pypi/mitmproxy","source":"PYSEC-2026-1630"}],"prev":{"headline":"Argo CD does not scrub secret values from patch errors","id":"CVE-2025-23216"},"products":["mitmproxy"],"published":"2025-02-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-12","vendors":["mitmproxy"]},"summary":"Attackers can bypass authentication via the proxy server to access internal APIs, potentially leading to remote code execution in mitmweb.","url":"https://insights.sbomify.com/CVE-2025-23217/"}