# CVE-2025-23217: Mitmweb API Authentication Bypass Using Proxy Server

> Attackers can bypass authentication via the proxy server to access internal APIs, potentially leading to remote code execution in mitmweb.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Feb 2025
- **Updated:** 12 Feb 2025
- **Also known as:** DEBIAN-CVE-2025-23217, GHSA-wg33-5h85-7q5p, PYSEC-2026-1630, UBUNTU-CVE-2025-23217

## What is CVE-2025-23217?

CVE-2025-23217 is a high-severity authentication bypass vulnerability in mitmproxy, published on 6 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

mitmproxy is a interactive TLS-capable intercepting HTTP proxy for penetration testers and software developers and mitmweb is a web-based interface for mitmproxy. In mitmweb 11.1.1 and below, a malicious client can use mitmweb's proxy server (bound to `*:8080` by default) to access mitmweb's internal API (bound to `127.0.0.1:8081` by default). In other words, while the cannot access the API directly, they can access the API through the proxy. An attacker may be able to escalate this SSRF-style access to remote code execution. The mitmproxy and mitmdump tools are unaffected. Only mitmweb is affected. This vulnerability has been fixed in mitmproxy 11.1.2 and above. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-441 (Unintended Proxy or Intermediary), CWE-288 (Authentication Bypass Using an Alternate Path or Channel)

## Which versions are affected by CVE-2025-23217?

3 open source packages ship an affected version, including mitmproxy.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mitmproxy` | PyPI | All versions | 11.1.2 |
| `mitmproxy` | PyPI | All versions | 11.1.2 |
| `mitmproxy` | PyPI | All versions | 11.1.2 |

## How do I fix CVE-2025-23217?

Upgrade mitmproxy to 11.1.2 or later.

## Is CVE-2025-23217 being exploited?

There is no known exploitation of CVE-2025-23217 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-23217 and fix it if it is affected.

What it is: CVE-2025-23217 is a high-severity authentication bypass vulnerability in mitmproxy, published on 6 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-23217 in the wild and no public exploit code.

Affected packages and fixed versions:
- mitmproxy (PyPI): affected all versions; fixed in 11.1.2
- mitmproxy (PyPI): affected all versions; fixed in 11.1.2
- mitmproxy (PyPI): affected all versions; fixed in 11.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-23217/ (Markdown: https://insights.sbomify.com/CVE-2025-23217/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-23217
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-23217
- OSV: https://osv.dev/vulnerability/CVE-2025-23217

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-23217/
Summaries are generated and may contain mistakes; the official description above is the record.
