# CVE-2025-23266: NVIDIA Container Toolkit for all platforms contains an Untrusted Search Path

> Attackers can execute arbitrary code with elevated permissions via container initialization hooks, leading to privilege escalation and data tampering.

- **Severity:** Critical 9.0 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2025
- **Updated:** 26 Feb 2026
- **Also known as:** ALSA-2025:13673, ALSA-2025:13674, AZL-65648, AZL-65651, GHSA-vmg3-7v43-9g23, GO-2025-3992, RHSA-2025:13673, RHSA-2025:13674

## What is CVE-2025-23266?

CVE-2025-23266 is a critical vulnerability in NVIDIA Container Toolkit, published on 17 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

NVIDIA Container Toolkit for all platforms contains a vulnerability in some hooks used to initialize the container, where an attacker could execute arbitrary code with elevated permissions. A successful exploit of this vulnerability might lead to escalation of privileges, data tampering, information disclosure, and denial of service.

Weakness: CWE-426 (Untrusted Search Path)

## Which versions are affected by CVE-2025-23266?

12 open source packages ship an affected version, including github.com/NVIDIA/nvidia-container-toolkit, github.com/NVIDIA/gpu-operator and github.com/NVIDIA/k8s-device-plugin.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/NVIDIA/nvidia-container-toolkit` | Go | All versions | 1.17.8 |
| `github.com/NVIDIA/nvidia-container-toolkit` | Go | All versions | 1.17.8 |
| `github.com/NVIDIA/nvidia-container-toolkit` | Go | All versions | 1.17.8 |
| `github.com/NVIDIA/gpu-operator` | Go | All versions | None |
| `github.com/NVIDIA/gpu-operator` | Go | All versions | 25.3.2 |
| `github.com/NVIDIA/gpu-operator` | Go | All versions | 25.3.2 |
| `github.com/NVIDIA/k8s-device-plugin` | Go | All versions | 0.17.3 |
| `github.com/NVIDIA/k8s-device-plugin` | Go | All versions | 0.17.3 |
| `github.com/NVIDIA/k8s-device-plugin` | Go | All versions | 0.17.3 |
| `github.com/NVIDIA/mig-parted` | Go | All versions | 0.12.2 |
| `github.com/NVIDIA/mig-parted` | Go | All versions | 0.12.2 |
| `github.com/NVIDIA/mig-parted` | Go | All versions | 0.12.2 |
| `toolbox` | AlmaLinux:10 | All versions | 0.2-1.el10_0 |
| `toolbox-tests` | AlmaLinux:10 | All versions | 0.2-1.el10_0 |
| `toolbox` | AlmaLinux:9 | All versions | 0.2-1.el9_6 |
| `toolbox-tests` | AlmaLinux:9 | All versions | 0.2-1.el9_6 |
| `toolbox` | Red Hat:enterprise_linux:10.0 | All versions | 0:0.2-1.el10_0 |
| `toolbox-debuginfo` | Red Hat:enterprise_linux:10.0 | All versions | 0:0.2-1.el10_0 |
| `toolbox-debugsource` | Red Hat:enterprise_linux:10.0 | All versions | 0:0.2-1.el10_0 |
| `toolbox-tests` | Red Hat:enterprise_linux:10.0 | All versions | 0:0.2-1.el10_0 |
| `toolbox` | Red Hat:enterprise_linux:9::appstream | All versions | 0:0.2-1.el9_6 |
| `toolbox-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:0.2-1.el9_6 |
| `toolbox-debugsource` | Red Hat:enterprise_linux:9::appstream | All versions | 0:0.2-1.el9_6 |
| `toolbox-tests` | Red Hat:enterprise_linux:9::appstream | All versions | 0:0.2-1.el9_6 |

## How do I fix CVE-2025-23266?

Upgrade github.com/NVIDIA/nvidia-container-toolkit to 1.17.8 or later.

## Is CVE-2025-23266 being exploited?

There is no known exploitation of CVE-2025-23266 in the wild and no public exploit code.

Public exploit code:

- PoC for NVIDIAScape bug (github_poc): https://github.com/jpts/cve-2025-23266-poc
- CVE-2025-23266 targets FastAPI’s parse_request() function, where oversized HTTP headers cause a buffer overflow and remote code execution. The article explains how attackers can escape container boundaries, compromise AI workloads, and how tools like Sentinel can detect and mitigate the threat (github_poc): https://github.com/mrk336/CVE-2025-23266
- CVE-2025-23266 – Fully Weaponized NVIDIA Container Toolkit Exploit (github_poc): https://github.com/r0binak/CVE-2025-23266
- cve-2025-23266-migration-bypass (github_poc): https://github.com/Mindasy/cve-2025-23266-migration-bypass
- Original offensive security research into Linux container boundary weaknesses. Whitepaper 1: OCI hook isolation failures in the NVIDIA Container Toolkit (CVE-2025-23266) under rootless Podman — four-way runc/crun comparison. (github_poc): https://github.com/CR1MS0N-Operator/security-research

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-23266 and fix it if it is affected.

What it is: CVE-2025-23266 is a critical vulnerability in NVIDIA Container Toolkit, published on 17 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-23266 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/NVIDIA/nvidia-container-toolkit (Go): affected all versions; fixed in 1.17.8
- github.com/NVIDIA/nvidia-container-toolkit (Go): affected all versions; fixed in 1.17.8
- github.com/NVIDIA/nvidia-container-toolkit (Go): affected all versions; fixed in 1.17.8
- github.com/NVIDIA/gpu-operator (Go): affected all versions; no fix listed
- github.com/NVIDIA/gpu-operator (Go): affected all versions; fixed in 25.3.2
- github.com/NVIDIA/gpu-operator (Go): affected all versions; fixed in 25.3.2
- github.com/NVIDIA/k8s-device-plugin (Go): affected all versions; fixed in 0.17.3
- github.com/NVIDIA/k8s-device-plugin (Go): affected all versions; fixed in 0.17.3
- github.com/NVIDIA/k8s-device-plugin (Go): affected all versions; fixed in 0.17.3
- github.com/NVIDIA/mig-parted (Go): affected all versions; fixed in 0.12.2
- github.com/NVIDIA/mig-parted (Go): affected all versions; fixed in 0.12.2
- github.com/NVIDIA/mig-parted (Go): affected all versions; fixed in 0.12.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-23266/ (Markdown: https://insights.sbomify.com/CVE-2025-23266/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-23266
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-23266
- OSV: https://osv.dev/vulnerability/CVE-2025-23266

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-23266/
Summaries are generated and may contain mistakes; the official description above is the record.
