# CVE-2025-23267: NVIDIA Container Toolkit for all platforms contains a vulnerability in the update-ldcache hook

> An attacker can exploit a link following vulnerability in the update-ldcache hook to tamper with data and cause denial of service.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2025
- **Updated:** 4 Nov 2025
- **Also known as:** GHSA-67jc-hmvg-q4c7, GO-2025-3998

## What is CVE-2025-23267?

CVE-2025-23267 is a high-severity path traversal vulnerability in NVIDIA Container Toolkit, published on 17 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

NVIDIA Container Toolkit for all platforms contains a vulnerability in the update-ldcache hook, where an attacker could cause a link following by using a specially crafted container image. A successful exploit of this vulnerability might lead to data tampering and denial of service.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2025-23267?

12 open source packages ship an affected version, including github.com/NVIDIA/nvidia-container-toolkit, github.com/NVIDIA/gpu-operator and github.com/NVIDIA/k8s-device-plugin.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/NVIDIA/nvidia-container-toolkit` | Go | All versions | 1.17.8 |
| `github.com/NVIDIA/nvidia-container-toolkit` | Go | All versions | 1.17.8 |
| `github.com/NVIDIA/nvidia-container-toolkit` | Go | All versions | 1.17.8 |
| `github.com/NVIDIA/gpu-operator` | Go | All versions | None |
| `github.com/NVIDIA/gpu-operator` | Go | All versions | 25.3.2 |
| `github.com/NVIDIA/gpu-operator` | Go | All versions | 25.3.2 |
| `github.com/NVIDIA/k8s-device-plugin` | Go | All versions | 0.17.3 |
| `github.com/NVIDIA/k8s-device-plugin` | Go | All versions | 0.17.3 |
| `github.com/NVIDIA/k8s-device-plugin` | Go | All versions | 0.17.3 |
| `github.com/NVIDIA/mig-parted` | Go | All versions | 0.12.2 |
| `github.com/NVIDIA/mig-parted` | Go | All versions | 0.12.2 |
| `github.com/NVIDIA/mig-parted` | Go | All versions | 0.12.2 |

## How do I fix CVE-2025-23267?

Upgrade github.com/NVIDIA/nvidia-container-toolkit to 1.17.8 or later.

## Is CVE-2025-23267 being exploited?

There is no known exploitation of CVE-2025-23267 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-23267 and fix it if it is affected.

What it is: CVE-2025-23267 is a high-severity path traversal vulnerability in NVIDIA Container Toolkit, published on 17 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-23267 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/NVIDIA/nvidia-container-toolkit (Go): affected all versions; fixed in 1.17.8
- github.com/NVIDIA/nvidia-container-toolkit (Go): affected all versions; fixed in 1.17.8
- github.com/NVIDIA/nvidia-container-toolkit (Go): affected all versions; fixed in 1.17.8
- github.com/NVIDIA/gpu-operator (Go): affected all versions; no fix listed
- github.com/NVIDIA/gpu-operator (Go): affected all versions; fixed in 25.3.2
- github.com/NVIDIA/gpu-operator (Go): affected all versions; fixed in 25.3.2
- github.com/NVIDIA/k8s-device-plugin (Go): affected all versions; fixed in 0.17.3
- github.com/NVIDIA/k8s-device-plugin (Go): affected all versions; fixed in 0.17.3
- github.com/NVIDIA/k8s-device-plugin (Go): affected all versions; fixed in 0.17.3
- github.com/NVIDIA/mig-parted (Go): affected all versions; fixed in 0.12.2
- github.com/NVIDIA/mig-parted (Go): affected all versions; fixed in 0.12.2
- github.com/NVIDIA/mig-parted (Go): affected all versions; fixed in 0.12.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-23267/ (Markdown: https://insights.sbomify.com/CVE-2025-23267/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-23267
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-23267
- OSV: https://osv.dev/vulnerability/CVE-2025-23267

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-23267/
Summaries are generated and may contain mistakes; the official description above is the record.
