{"answers":{"affected":"2 open source packages ship an affected version, including org.jboss.hal:hal-console. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-23366 in the wild and no public exploit code.","fix":"Upgrade org.jboss.hal:hal-console to 3.7.7.Final or later.","what":"CVE-2025-23366 is a medium-severity cross-site scripting vulnerability in Red Hat JBoss Data Grid 7, published on 14 Jan 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-23366 and fix it if it is affected.\n\nWhat it is: CVE-2025-23366 is a medium-severity cross-site scripting vulnerability in Red Hat JBoss Data Grid 7, published on 14 Jan 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-23366 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jboss.hal:hal-console (Maven): affected all versions; fixed in 3.7.7.Final\n- org.jboss.hal:hal-console (Maven): affected all versions; fixed in 3.7.7.Final\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-23366/ (Markdown: https://insights.sbomify.com/CVE-2025-23366/index.md)","id":"CVE-2025-23366","markdown":"https://insights.sbomify.com/CVE-2025-23366/index.md","name":"CVE-2025-23366","record":{"aliases":["GHSA-jhvj-f397-8w6q"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"WildFly HAL Console","requires_auth":"high_privilege","summary":"Authenticated administrators can inject scripts into the WildFly HAL Console, potentially leading to code execution or account takeover.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"hal_management_console","vendor":"redhat"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A flaw was found in the HAL Console in the Wildfly component, which does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output used as a web page that is served to other users. The attacker must be authenticated as a user that belongs to management groups “SuperUser”, “Admin”, or “Maintainer”.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Org.jboss.hal:hal-console: wildfly hal console cross-site scripting","id":"CVE-2025-23366","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":6,"next":{"headline":"Org.wildfly.core:wildfly-server: wildfly improper rbac permission","id":"CVE-2025-23367"},"packages":[{"ecosystem":"Maven","fixed":["3.7.7.Final"],"introduced":["0"],"last_affected":[],"package":"org.jboss.hal:hal-console","purl":null,"source":"GHSA-jhvj-f397-8w6q"},{"ecosystem":"Maven","fixed":["3.7.7.Final"],"introduced":["0"],"last_affected":[],"package":"org.jboss.hal:hal-console","purl":"pkg:maven/org.jboss.hal/hal-console","source":"GHSA-jhvj-f397-8w6q"}],"prev":{"headline":"Privilege escalation in TIA Administrator","id":"CVE-2025-23365"},"products":["Red Hat JBoss Data Grid 7","Red Hat JBoss Enterprise Application Platform 7","Red Hat JBoss Enterprise Application Platform 8","Red Hat JBoss Enterprise Application Platform Expansion Pack"],"published":"2025-01-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-19","vendors":["Red Hat"]},"summary":"Authenticated administrators can inject scripts into the WildFly HAL Console, potentially leading to code execution or account takeover.","url":"https://insights.sbomify.com/CVE-2025-23366/"}