# CVE-2025-23366: Org.jboss.hal:hal-console: wildfly hal console cross-site scripting

> Authenticated administrators can inject scripts into the WildFly HAL Console, potentially leading to code execution or account takeover.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jan 2025
- **Updated:** 19 Aug 2026
- **Also known as:** GHSA-jhvj-f397-8w6q

## What is CVE-2025-23366?

CVE-2025-23366 is a medium-severity cross-site scripting vulnerability in Red Hat JBoss Data Grid 7, published on 14 Jan 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A flaw was found in the HAL Console in the Wildfly component, which does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output used as a web page that is served to other users. The attacker must be authenticated as a user that belongs to management groups “SuperUser”, “Admin”, or “Maintainer”.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-23366?

2 open source packages ship an affected version, including org.jboss.hal:hal-console. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jboss.hal:hal-console` | Maven | All versions | 3.7.7.Final |
| `org.jboss.hal:hal-console` | Maven | All versions | 3.7.7.Final |

Products: Redhat Hal Management Console.

## How do I fix CVE-2025-23366?

Upgrade org.jboss.hal:hal-console to 3.7.7.Final or later.

## Is CVE-2025-23366 being exploited?

There is no known exploitation of CVE-2025-23366 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-23366 and fix it if it is affected.

What it is: CVE-2025-23366 is a medium-severity cross-site scripting vulnerability in Red Hat JBoss Data Grid 7, published on 14 Jan 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-23366 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jboss.hal:hal-console (Maven): affected all versions; fixed in 3.7.7.Final
- org.jboss.hal:hal-console (Maven): affected all versions; fixed in 3.7.7.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-23366/ (Markdown: https://insights.sbomify.com/CVE-2025-23366/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-23366
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-23366
- OSV: https://osv.dev/vulnerability/CVE-2025-23366

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-23366/
Summaries are generated and may contain mistakes; the official description above is the record.
